PDA

Zobacz pełną wersję : Joomla 1.0.9



Nolt
10-03-2006, 01:17
Cześć. Jestem nowym urzytkownikiem joomla tzn uzywam tego portalu od niedawna, i mam pytanko. Przeczytalem na stronie ze nowa wyjdzie w niedlugim czasie nowa joomla 1.0.9 i czy jesli moj portal stoi na wersji 1.0.8 to jak mam dokonac aktualizacji ? I czy moje istniejące dane znikną ? Sorry za takie banalne pytanie ale poprostu nie wiem :) Pozdro.

viper
10-03-2006, 01:28
Nową wersją nadpiszesz pliki starszej wersji, to w uproszczeniu . A każdy artykuł jest zapisany w bazie danych i nie stracisz tego.

Nolt
10-03-2006, 02:48
czyli wszystkie nowe pliki kopiuje do starej lokalizacji ale bez folderu install ? czy on tez jest potrzebny ?
dzieki za odpowiedz.

Dylek
10-03-2006, 07:36
Zawsze razem z nowa wersja ukazuja sie tez patche uaktualniajace poprzednie wersje do tej najnowszej. W Twoim przypadku sciagniesz sobie patcha o naziwe powiedzmy 108_to_109_patch.tar.gz i plikami w nim zawartymi nadpiszesz swoje pliki na serwerze.
Dosc istotna uwaga: Mowie tu o wersji angielskiej lub wersji z joomlapl.com. Wersja z joomla.pl bedzie miala troche inny przebieg aktualizacji.

gielo
24-03-2006, 13:16
Zawsze razem z nowa wersja ukazuja sie tez patche uaktualniajace poprzednie wersje do tej najnowszej. W Twoim przypadku sciagniesz sobie patcha o naziwe powiedzmy 108_to_109_patch.tar.gz i plikami w nim zawartymi nadpiszesz swoje pliki na serwerze.


Chyba nie do końca, ja nie mogłem znaleźć patcha do 1.08PL czyli do polskiej wersji więc nadpisałem starą i działa. Pominąłem tylko plik concig czy jakoś tak :rolleyes:

Rybik
30-03-2006, 00:45
Wszystko to ładnie opisano w planie rozwoju Joomla (tutaj) (http://www.joomla.pl/index.php/content/view/106/52/). Obecna struktura, rodzaj i sposób dokonywanych poprawek gwarantuje pełną kompatybilność w zakresie poprawek (1.0.8), sporą w zakresie podwersji (1.0.8) i wręcz pewny brak kompatybilności w zakresie wersji (1.0.8). Stąd też upgrade wersji poprawek (1.0.8 -> 1.0.9 i podobne aktualizacje) przebiega zawsze bezkonfliktowo przez nadpisanie plików zamieszczonych w patchu. Użycie ANG patcha na Joomli PL nie powinno wpłynąc na funkcjonowanie portalu, co najwyżej gdzieś może się wysypać kodowanie znaków lub angielskie teksty.
Upgrade podwersji, o ile jest możliwy, będzie szeroko opisany - jednak każda wersja i podwersja stanowi po ukazaniu się w formie stabilnej odrębna drogę rozwojową - i o ile upgrade wersji poprawek jest zawsze zalecany - bo poprawia błędy i stabilność, o tyle zmiana podwersji to juz kwestia obierania nowej drogi i dla istniejących i sprawnie funkcjonujących witryn jest mało komfortowa, a często wręcz zbędna.