PDA

Zobacz pełną wersję : Joomla 1.0.13 i MySQL >=5???



metmusic
07-02-2008, 20:04
Mam problem z zainstalowaniem Joomli 1.0.13 ponieważ wyskakuje mi komunikat z błędami przy tworzeniu bazy.

Instaluje Joomle lokalnie.
Mam:
Apache 2.2.8 nossl
PHP 5.2.5
MySQL 5.0.51a

Komunikat o błędzie w 2gim kroku:

SQL=BLOB/TEXT column \'text\' can\'t have a default value SQL=# Table structure for table `jos_poll_data`
\n
\nCREATE TABLE `jos_poll_data` (
\n `id` int(11) NOT NULL auto_increment,
\n `pollid` int(4) NOT NULL default \'0\',
\n `text` text NOT NULL default \'\',
\n `hits` int(11) NOT NULL default \'0\',
\n PRIMARY KEY (`id`),
\n KEY `pollid` (`pollid`,`text`(1))
\n) TYPE=MyISAM DEFAULT CHARSET=latin2:
- - - - - - - - - -
# Table structure for table `#__poll_data`

CREATE TABLE `#__poll_data` (
`id` int(11) NOT NULL auto_increment,
`pollid` int(4) NOT NULL default '0',
`text` text NOT NULL default '',
`hits` int(11) NOT NULL default '0',
PRIMARY KEY (`id`),
KEY `pollid` (`pollid`,`text`(1))
) TYPE=MyISAM DEFAULT CHARSET=latin2
= = = = = = = = = =

ma ktos pomysł co z tym fantem zrobić? jak zobaczyłem Joomla baze tworzy ale nie wiem czy jak nalezy. Nie zmienia to jednak postaci rzeczy, że nie mogę przejśc do następnego kroku
z góry dzięki za pomoc

Joomla 1.5 instaluje się bez problemów.

Marcin

zwiastun
07-02-2008, 20:25
W pliku /installation/language/sql/joomla.sql
zamień przytoczony tekst kwerendy na poniższy


CREATE TABLE `#__poll_data` (
`id` int(11) NOT NULL auto_increment,
`pollid` int(4) NOT NULL default '0',
`text` text NOT NULL,
`hits` int(11) NOT NULL default '0',
PRIMARY KEY (`id`),
KEY `pollid` (`pollid`,`text`(1))
)

metmusic
07-02-2008, 20:32
teraz pojawił się następny i to już znacznie poważniejszy :/


SQL=You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'# $Id: joomla.sql 677 2007-08-14 02:13:29Z zwiastun $
\n
\n# Table structure fo\' at line 1 SQL=# $Id: joomla.sql 677 2007-08-14 02:13:29Z zwiastun $
\n
\n# Table structure for table `jos_banner`
\n
\nCREATE TABLE `jos_banner` (
\n `bid` int(11) NOT NULL auto_increment,
\n `cid` int(11) NOT NULL default \'0\',
\n `type` varchar(10) NOT NULL default \'banner\',
\n `name` varchar(50) NOT NULL default \'\',
\n `imptotal` int(11) NOT NULL default \'0\',
\n `impmade` int(11) NOT NULL default \'0\',
\n `clicks` int(11) NOT NULL default \'0\',
\n `imageurl` varchar(100) NOT NULL default \'\',
\n `clickurl` varchar(200) NOT NULL default \'\',
\n `date` datetime default NULL,
\n `showBanner` tinyint(1) NOT NULL default \'0\',
\n `checked_out` tinyint(1) NOT NULL default \'0\',
\n `checked_out_time` datetime NOT NULL default \'0000-00-00 00:00:00\',
\n `editor` varchar(50) default NULL,
\n `custombannercode` text,
\n PRIMARY KEY (`bid`),
\n KEY `viewbanner` (`showBanner`)
\n) TYPE=MyISAM DEFAULT CHARSET=latin2 AUTO_INCREMENT=1:
- - - - - - - - - -
# $Id: joomla.sql 677 2007-08-14 02:13:29Z zwiastun $

# Table structure for table `#__banner`

CREATE TABLE `#__banner` (
`bid` int(11) NOT NULL auto_increment,
`cid` int(11) NOT NULL default '0',
`type` varchar(10) NOT NULL default 'banner',
`name` varchar(50) NOT NULL default '',
`imptotal` int(11) NOT NULL default '0',
`impmade` int(11) NOT NULL default '0',
`clicks` int(11) NOT NULL default '0',
`imageurl` varchar(100) NOT NULL default '',
`clickurl` varchar(200) NOT NULL default '',
`date` datetime default NULL,
`showBanner` tinyint(1) NOT NULL default '0',
`checked_out` tinyint(1) NOT NULL default '0',
`checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00',
`editor` varchar(50) default NULL,
`custombannercode` text,
PRIMARY KEY (`bid`),
KEY `viewbanner` (`showBanner`)
) TYPE=MyISAM DEFAULT CHARSET=latin2 AUTO_INCREMENT=1
= = = = = = = = = =

SQL=You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'CREATE TABLE `jos_poll_date` (
\n `id` bigint(20) NOT NULL auto_increment,
\n `d\' at line 14 SQL=# Table structure for table `jos_poll_data`
\n
\nCREATE TABLE `jos_poll_data` (
\n`id` int(11) NOT NULL auto_increment,
\n`pollid` int(4) NOT NULL default \'0\',
\n`text` text NOT NULL,
\n`hits` int(11) NOT NULL default \'0\',
\nPRIMARY KEY (`id`),
\nKEY `pollid` (`pollid`,`text`(1))
\n)
\n
\n# Table structure for table `jos_poll_date`
\n
\nCREATE TABLE `jos_poll_date` (
\n `id` bigint(20) NOT NULL auto_increment,
\n `date` datetime NOT NULL default \'0000-00-00 00:00:00\',
\n `vote_id` int(11) NOT NULL default \'0\',
\n `poll_id` int(11) NOT NULL default \'0\',
\n PRIMARY KEY (`id`),
\n KEY `poll_id` (`poll_id`)
\n) TYPE=MyISAM DEFAULT CHARSET=latin2:
- - - - - - - - - -
# Table structure for table `#__poll_data`

CREATE TABLE `#__poll_data` (
`id` int(11) NOT NULL auto_increment,
`pollid` int(4) NOT NULL default '0',
`text` text NOT NULL,
`hits` int(11) NOT NULL default '0',
PRIMARY KEY (`id`),
KEY `pollid` (`pollid`,`text`(1))
)

# Table structure for table `#__poll_date`

CREATE TABLE `#__poll_date` (
`id` bigint(20) NOT NULL auto_increment,
`date` datetime NOT NULL default '0000-00-00 00:00:00',
`vote_id` int(11) NOT NULL default '0',
`poll_id` int(11) NOT NULL default '0',
PRIMARY KEY (`id`),
KEY `poll_id` (`poll_id`)
) TYPE=MyISAM DEFAULT CHARSET=latin2
= = = = = = = = = =

zwiastun
07-02-2008, 20:35
Nie usunąłeś tabel po poprzedniej próbie instalacji.
Rozpocznij ją od nowa, usuń istniejące tabele.
Możesz je też usunąć ręcznie np. w phpMyAdminie

metmusic
07-02-2008, 20:39
Właśnie na moje nieszczęście usunąłem (Korzystam z MySQL Administrator) phpMyAdmin nie instalowałem sobie ale nie ma to znaczenia. Usuwam albo całą baze albo tylko tabele...efekt ten sam...dziwne.

metmusic
07-02-2008, 20:47
Wracając do poprzedniej wersji kwerendy dla polls spowrotem pojawia się ten pierwszy komunikat. Dając ten co Ty proponujesz pojawia się zestaw tych drugich błędów...

Tabele napewno czyszczę za każdym razem i oprócz tego przy instalacji każe wyczyścić tabele.