PDA

Zobacz pełną wersję : Problem przy instalacji modulu IP info .... ? (moj pierwszy raz :) )



AdamK
23-02-2008, 13:17
Witam.
Mam problem z instalacja oboetnie jakiego modulu. Postanowilem skupic sie na jednym :). Poczytalem na forum o kodowaniu UTF i ISO. Znalzlem, ze ktos pisal o tym, ze w pliku xml nie moga byc polskie znaki ... Szukam sprawdzam i ....porazka...
Kmunikat standardowy :
brak pliku XML lub kodowanie pliku jest niepoprawne
Sam juz nie wiem o co biega ...
Czytalem w ksiazce do joomli ale tam nic nie ma tylko jak sie instaluje modul ... wskazac plik zip i juz ....
Modul nad ktorym sie skupilem w probie zainstalowania to ... IP info pobrany z joomla.pl
Tak wyglad plik xml. Wstawilem w nim kodowanie. Usunalem polskie znaki.... i nic. Takie mam chyba kodowanie stronki bo wzialem inny bodul z niej i sprawdzilem. Nie wiem czy to dobrze zrobilem.

Prosze o pomoc i z gory dziekuje
Pozdrawiam
Adam
<?xml version="1.0" encoding="iso-8859-1" ?>
- (file:///D:/mod_ip_info.xml#) <mosinstall type="module">
<name>IP and Domain Info</name>

<creationDate>21/12/2003</creationDate>

<author>aka Raydian Hood</author>

<copyright>This module is released under the GNU/GPL License</copyright>

<authorEmail />

<authorUrl>http://www.webraydian.com</authorUrl>

<version>1.0</version>

<description>Modul wyswietla IP uzytkownika, domene oraz (jezeli uzywa) IP serwera proxy</description>

- (file:///D:/mod_ip_info.xml#) <files>
<filename module="mod_ip_info">mod_ip_info.php</filename>

</files>


</mosinstall>

inkos
23-02-2008, 14:25
Wstawilem w nim kodowanie. Usunalem polskie znaki.... i nic. Takie mam chyba kodowanie stronki bo wzialem inny bodul z niej i sprawdzilem. Nie wiem czy to dobrze zrobilem.
Proponuję dokładniejszą lekturę tego forum w temacie kodowania. Jest tam wszystko opisane już wielokrotnie. Co do samego modułu i błędu. Jeśli masz jakiś moduł który udało Ci się zainstalować to rozpakuj sobie na komputerze jego paczkę i podejrzyj jak wygląda plik .xml i porównaj z tym co masz u siebie. Porównaj i będziesz już wiedział co jak należy zrobić a co jest błędem. ;) Nie pisze Ci gotowego rozwiązania abyś mógł samemu do niego dojść. Jesli chcesz się czegoś nauczyć z Joomla! to najlepiej jak Ci się uda dojść do tego samemu. Wtedy satysfakcja jest gwarantowana. :D

Poczytaj sobie też strony pomoc.joomla.pl i demo.joomla.pl (także w temacie tego problemu).