PDA

Zobacz pełną wersję : Nie widzi w ogole obrazka w IE PILNA POMOC PROSZE



pezet40
17-03-2008, 11:50
Witam. Mam problem. W IE w ogole nie pokazuje mi pewnego waznego gifa (dotyczacego gornego menu)... Gdyby sie przesunal czy cos to dalbym rade ale jego w ogole nie ma... Chyba sie schowal pod tlem... Nie moge dac linka gdyz strona jest robiona dla instytucji panstwowej... Oczywiscie w firefoxie jest ok... Ale dam screeny...

Oto Kod odpowiedzialny w css za ten Plik ktory mi nie dziala (Plik nazywa sie mod_12) a pozostale chodza te pliki typu mod_27 itd

[code] #left .moduletable h3, #left .module h3, #right .moduletable h3, #right .module h3 {
font-weight: bold;
font-size: 1em;
margin-bottom: 15px;
text-align: center;
margin-top: 0;
margin-right: 0;
margin-left: 0;
text-indent: -5px;
color: #333333;
font-family: Arial, Helvetica, sans-serif;
padding-top: 2px;
}
#left .module {
width: 163px;
background: url(../images/mod_17.gif) repeat-y;
margin-bottom: 7px;
padding-right: 5px!important;
padding-right: 5px;
margin-left: 15px;
}
#right .module {
width: 163px;
background: url(../images/mod_17.gif) repeat-y;
margin-bottom: 7px;
margin-left: 7px;
padding-right: 10px!important;
padding-right: 10px;
text-align: left;
}

#left .module div {
background: url(../images/mod_27.gif) bottom left no-repeat;
}
#right .module div {
background: url(../images/mod_27.gif) bottom left no-repeat;
}

#left .module div div {
background: url(../images/mod_12.gif) top left repeat-y;
padding-top: 7px;
padding-right: 5px!important;
padding-bottom: 15px;
padding-left: 6px;
}

#right .module div div {
background: url(../images/mod_12.gif) top left repeat-y;
padding-top: 7px;
padding-right: 5px!important;
padding-bottom: 15px;
padding-left: 6px;
}
#left .module div div div, #right .module div div div {
background: none;
padding: 0;
width: auto !important;
width: 100%;
}
#nav ul {
margin: 0;
padding: 0;
list-style:none;
}

pezet40
17-03-2008, 11:57
background: url(../images/mod_12.gif) top left repeat-y;

Ps. oczywiscie w tych linijkach mam no-repeat ..... tylko tak testowalem co sie pojawi...

Dam tez index.php ponizej...


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<?php
defined( '_VALID_MOS' ) or die( 'Direct Access to this location is not allowed.' ); ?>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2">
<link href="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe-> getTemplate(); ?>/css/template_css.css" rel="stylesheet" type="text/css" media="all"/>
<link rel="shortcut icon" href="<?php echo $mosConfig_live_site;?>/images/favicon.ico" />
<?php
if ( $my->id ) {
initEditor();
}
mosShowHead();
?>
<style type="text/css">
<!--
body {
margin-top: 0px;
}
-->
</style></head>
<body id="page_bg"><table width="950" border="0" align="center" cellpadding="0" cellspacing="0">
<tr>
<td><div id="header"><div id="search"><?php mosLoadModules ( 'user5', -3 ); ?></div>
</div> </td>
</tr>
<tr>
<td><div id="nav"><?php mosLoadModules ( 'top', -3 ); ?></div></td>
</tr>
<tr>
<td><div id="main_top"></div></td>
</tr>
<tr>
<td><table border="0" cellspacing="0" cellpadding="3" id="main">
<tr>
<td valign="top"><div id="left">
<?php mosLoadModules ( 'left', -3); ?>
<br />
<?php mosLoadModules ( 'user1', -3 ); ?>
</div></td>
<td width="100%" align="left" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="3">
<tr>
<td><?php if (mosCountModules('user2')) { ?>
<div id="user2">
<?php mosLoadModules ( 'user2', -3 ); ?>
<? } ?>
</div><?php if (mosCountModules('user3')) { ?>
<div id="user3"><?php mosLoadModules ( 'user3', -3 ); ?>
</div><? } ?>
</td>
</tr>
<tr>
<td><?php mosMainBody(); ?></td>
</tr>
</table></td>
<td valign="top"><?php if (mosCountModules('right')) { ?>
<div id="right">
<?php mosLoadModules ( 'right', -3 ); ?>
</div>
<? } ?></td>
</tr>
</table></td>
</tr>
<tr>
<td><div id="main_bottom"><?php include_once('includes/footer.php'); ?></div></td>
</tr>
</table>

<div class="validate" align="center">

&nbsp;</div>
<?php mosLoadModules( 'debug', -1 );?>
</body>
</html>