PDA

Zobacz pełną wersję : Art*Forms v.2b5dev PL - parse error, unexpected $end in...



pirex
18-11-2005, 23:54
Witam zainstalowałem komponent Art*Forms v.2b5dev PL na Joomle 1.0.3 i teraz gdy wybiorę cokolwiek z menu tzn. czy wezmę Stwórz formularz, Edytuj język, Instrukcja czy O Art*Forms dostaję taki błąd:



Parse error: parse error, unexpected $end in C:\usr\apache\httpd\html\administrator\components\ com_artforms\admin.artforms.php on line 460


A oto linie 440-460 z pliku admin.artforms.php:



HTML_artforms::showLanguage($file,$option);
}

function saveLanguage($file, $filecontent, $option) {

@chmod ($file, 0766);
$permission = is_writable($file);
if (!$permission) {
mosRedirect("index2.php?option=$option&task=language", ADM_ARTForms_ERROR_J);
break;
}

if ($fp = fopen( $file, "w")) {
fputs($fp,stripslashes($filecontent));
fclose($fp);
mosRedirect( "index2.php?option=$option&task=language", ARTForms_filesaved );
}
}

FormsFooter($ArtForms_version);
?>


Z góry dzięki za pomoc...

zwiastun
19-11-2005, 00:56
Bardzo jestem ciekaw, skąd pobrałeś Art*Forms v.2b5dev PL dla Joomla 1.03?
Nie pamiętam, zebym takową wersję udostępniał dla Joomla 1.03, no ale może ktoś inny to uczynił?

Coby Cię jeszcze nieco pomęczyć, to dodam, że w przytoczonym fragmencie akurat błędu nie ma.

Żeby pomęczyć jeszcze bardziej, uzupelnię, że w całym tym pliku nie ma błędu.

Abyś się czul zupelnie pogrążony, dołożę, że to przez ten serwer, na którym to zainstalowałeś.

A najgorsze w tym to to, że serwer ma pewno ustawienia zgodne z wymaganiami joomli primo voto mambo.

No to pora tę tajemnicę odsłonić. Rzecz w short tags.

Oczywiscie, nie o majtki (szorty) chodzi, ale o znaczniki.
Autor komponentu użył zamiast np. <?php po prostu <? i zamiast <?php echo - <? echo

Teraz - na wątpliwe pociesznie, nie zrobil tego w jednym tylko pliku, lecz w kilku

Lekarstwo: pozamieniać
Problem: Możliwe, że nie będziesz teraz w stanie odinstalować tego komponentu, jeśli Ci Joomla zmienia prawa do katalogów.

Jeśli nie zmienia, to ok. 30 minut pracy - przeszukania wszystkich skryptów i dokonania odpowiednich zmian!

Powodzenia!

pirex
19-11-2005, 01:39
Nie pisałem, że pobrałem Art*Forms v.2b5dev PL dla Joomla 1.0.3 - ale zainstalowałem na Joomla 1.0.3:) Pobrałem to z joomlademo.pl a tam nigdzie nie ma informacji o zgdoności:) Mam tylk pytanie, czy jest nowsza lub starszawersja tego komponentu pod Joomle 1.0.3 - nie pyam się z skad pobrać, ale czy wogule istnieje...

zwiastun
19-11-2005, 07:13
A co się zaraz obruszasz!!!
1. Pobierałeś komponent z katalogu przeznaczonych dla mambo. Masz rację, nie pisze nic o zgodności z joomla! I masz, oczywiście prawo nie wiedzieć, że komponent wydany kilka miesięcy temu nie musi być zgodny z mambo. Ale to akurat nie ma znaczenia.
Mam nadzieję, że następnym razem nie dostanę tu opr za to, że na kilkuset stronicach, na joomlademo o mambo nie ma napisane, że to dotyczy TYLKO mambo, a w joomla może być inaczej.
Doskonale wiem, żeś nie pobrał komponentu do joomla 1.03, bo nie został opublikowany w polskiej wersji.


Mam tylk pytanie, czy jest nowsza lub starszawersja tego komponentu pod Joomle 1.0.3 - nie pyam się z skad pobrać, ale czy wogule istnieje...
A tego to już w ogóle nie rozumiem!
Sądzisz, że dla zabawy poświęciłem Ci kilka ładnych minut na odpowiedź? I sądzisz, że gdyby był, to nie podałbym Ci informacji?
Teraz rzeczywiście mam ochotę skierować Cię do najnowszego wydania Art*Forms. Może jak się pomęczysz, to poczytasz, co Ci ktoś życzliwie odpisuje!

Zrób co napisałem poprzednio i komponent będzie działał.

ewitka
08-05-2007, 13:20
Cześć, miałam ten sam błąd w zoom media gallery i rzeczywiście przy <? nie było php, poprawiłam - działa!
dzęki wielkie :)
Ewa