PDA

Zobacz pełną wersję : SH404SEF - Jak usunąć /index.php ze strony głównej?



daruuu
13-12-2008, 04:25
Zainstalowałem komponent SH404SEF. Komponent działa prawidłowo - zamienia adresy na przyjazne. Istnieje jednak problem z adresem strony głównej - zamiast adresu www.mojastrona.pl (http://www.strona.pl) jest www.mojastrona/index.php (http://www.strona/index.php)

Pozostałe adresy wyglądają poprawnie np. www.mojastrona.pl/wiadomosci (http://www.strona.pl/wiadomosci)

Przekierowanie strony głównej na /index.php wynika z wprowadzonych przeze mnie zmian w konfiguracji tzn. wpisania w zakładce "Advanced" w polu "Home page URL" wartości /index.php.

Niestety bez wpisania powyższej wartości przy próbie wejścia na stronę główną pojawia się błąd 404 - nie znaleziono komponentu.

Co ciekawe bez przypisanego w konfiguracji zaawansowanej /index.php pozostałe elementy strony funkcjonują poprawnie tzn. można wejść na stronę: www.mojastrona.pl/wiadomosci (http://www.strona.pl/wiadomosci) ale nie można na stronę główną www.mojastrona.pl (http://www.strona.pl)
Strona nie działa również po wpisaniu w przeglądarce www.mojastrona.pl/index.php (http://www.strona.pl/index.php) (błąd 404 - nie znaleziono komponentu)

Obecnie, aby strona główna działała musi być przypisany /index.php, jednak nie jest to dla mnie korzystne ze względu na pozycjonowanie (strona bez index.php zajmuje 1-2 pozycję w wyszukiwarkach na podstawowe słowo kluczowe)

Szukałem na forum Joomla oraz SH404SEF, a także w Google i niestety nie znalazłem rozwiązania.

.htaccess wygląda następująco


DirectoryIndex index.php
RewriteEngine On
RewriteBase /


RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]
RewriteCond %{REQUEST_URI} (/|.htm|.php|.html|/[^.]*)$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) /index.php
php_flag register_globals offw configuration.php przypisana zmienna:


var $live_site = 'http://mojastrona.pl'; System pracuje na:
Joomla 1.5.8
Sh404SEF 1.0.11_Beta - build_147Z góry dziękuję za pomoc

vego007
13-12-2008, 20:59
a zmieniłeś mod_rewrite na bez index.php w ustawieniach SEF??

daruuu
13-12-2008, 21:28
Dziękuje za odpowiedź

Oczywiście "rewriting mode" ustawione jest na "with .htaccess"

Wyjaśnię ponownie - wszystkie adresy podstron funkcjonują bez "index.php".
index.php pojawia się jedynie na stronie głównej, ponieważ ustawione tak jest w konfiguracji URL strony głównej.

Chciałbym się tego pozbyć, ale jak usuwam z konfiguracji "index.php" - pojawia się błąd 404 (pomimo, że błąd 404 jest na stronie głównej to pozostałe podstrony funkcjonują prawidłowo)

w załączniku zrzut ekranu mojej konfiguracji SH404SEF

maestro678
05-05-2009, 14:24
Mam dokładnie ten sam problem. Wszystko działa ok, poza strona startową na której mam błąd 404 - nie znaleziono. Jeżeli wymuszę w konfiguracji przekierowanie na index.php to niby działa - ale są problemy z logowaniem, do tego lipa jeśli chodzi o pozycjonowanie itp. bo nie pokazują się wtedy poprawnie meta tagi ze strony głównej... Ehh, szkoda gadać, same problemy.

Czy ktoś może coś na to poradzić ?

Max01
26-08-2009, 22:40
Witam

Też szukam rozwiązania tego problemu

MagicWawa
27-08-2009, 08:07
Pierwsza rzecz... Po co komponent? Joomla posiada proste adresy do ustawienia w konfiguracji.

http://www.gbcomp.website.pl/pic/konf.jpg

A jeśli już z komponentem, to spróbujcie wpisać zamiast /index.php sam /. Wedle wszelkiego prawdopodobieństwa powinno pomóc, bo / wskazuje na plik w głównym katalogu strony.

Max01
27-08-2009, 08:27
Dzięki MagicWawa

Już rozwiązałem problem. U mnie ta porada rozwiązała błąd http://forum.joomla.pl/showthread.php?t=16345&highlight=home.pl
(http://forum.joomla.pl/showthread.php?t=16345&highlight=home.pl)

nahagel
10-10-2009, 17:26
@MagicWawa
w dużej mierze masz racje - tez tak samo myślałem dopóki nie zacząłem tworzyć serwisów bardziej zaawansowanych, z dodatkowymi komponentami

@Max01
dzieki za linka - u mnie tez zadziałało - patch był rewelacyjny!