PDA

Zobacz pełną wersję : Wysyłanie Maili



socer
16-10-2005, 13:19
Jak ustawiś w golbal setting funkcje mail zeby wysyłało maile .

P.S server wyłączył funkcje sendmail

stone
16-10-2005, 13:23
najlepiej wpisz ustawienia smtp jakiegoś swojego konta e-mial, to najpewniejsza metoda

socer
16-10-2005, 22:03
No i tak zrobilem np wiziłem konto z o2.pl i niedziała :(

^f0rm@c!k_?
16-10-2005, 22:18
Ja miałem problem z WP... :mad:

A SMTP Host: - dobrze tu wpisałeś - ja nie wiem co na Tlenie się tu wpisuje i czy nie ma z nim problemów przy masowych mailach...

socer
16-10-2005, 22:23
Hmm w host smtp wpisałem poczta.o2.pl mam nadzieje ze tak ma byc :o

^f0rm@c!k_?
16-10-2005, 22:26
A reszta poprawnie...? Spróbuj w host może wpisać IP...

socer
16-10-2005, 22:29
ale czyje ip ?

^f0rm@c!k_?
16-10-2005, 23:00
Poczty tlenu...

stone
16-10-2005, 23:45
A jeszcze powiedz w jaki sposob sprawdzasz ze wysyla wiadomosci?

socer
17-10-2005, 15:12
A skąd mam wziąść ip Tlenu ?
Wysyłam miala (znaczy sprawdzam ) z kontakt bo tylko to jest mi poczebne

O tak mam ustawione !
(http://img162.imageshack.us/img162/3006/teee3no.jpg])
[IMG]http://img162.imageshack.us/img162/3006/teee3no.th.jpg (http://img162.imageshack.us/my.php?image=teee3no.jpg)

stone
17-10-2005, 16:28
Większośc kont pocztowych wymaga przy wysylaniu autoryzacji smtp , ustaw wiec autoryacje na 'tak' i wpisz swoje haslo do smtp (czyli konta pocztowego najczesciej)

^f0rm@c!k_?
17-10-2005, 18:53
Coś ten obrazek nie istnieje... :D

socer
18-10-2005, 16:12
Znaczy dałem tak i nic a kasło tylko wicąłem :P
I dalej niedziała

stone
18-10-2005, 16:18
a mozesz dac konto testowe do panelu admina
moze byc na pw

socer
19-10-2005, 07:18
1. Co to znaczy pw ?
2. Jak wy macie tam zrobione w smtp host ? bo mysle ze w tym jest problem !

stone
19-10-2005, 08:07
pw to jest 'prywatna wiadomosc' taka funkcja forum

a co do problemu to jezeli wpisales prawidlowo dane do smtp to porblem moze byc gdzie indziej.
Jezli, jak napiales, sprawdzasz kontaktem, to sprawdz jeszcze dokladnie czy kontakt ktorego uzywasz ma przypisany odpowiedni adres e-mail na ktory maja byc wysalne maile

vj_
19-10-2005, 20:02
socer: poczytaj sobie na przykład pare stron poświęconych autoryzacji poczty ot chociażby na wp.pl (http://poczta.wp.pl/autoryzacja/)

Załapiesz od razu o co chodzi :-) Powodzenia.

stone
19-10-2005, 20:06
dostalem od kolegi konto testowe i z tego co widzialem nie mial przypisanego uzytkownika do kontaktu i dlatego maile nie dochodzily, aczkolwiek jeszcze nie potwierdzil ze dziala

vj_
19-10-2005, 20:21
No, to całkiem możliwe, że na tym błąd polegał, ale lektura o autoryzacji koledze nie zaszkodzi :D A tak a propos wiadomości..pozwolę sobie w tym temacie na małym off-topic bowiem spojrzałem na panel po lewo i widzę dla przykładu:



Status: Offline
Wiadomości: 3
Dołączył: data
Skąd: miejscowość
Wiadomości: 3




dlaczego są podwójnie "Wiadomości" ? :-)

Pierwotnie jest nieco inaczej, ale może się mylę, w każdym razie gafa mało istotna, ale jak się udaje w trakcie prac coś takiego na bieżąco wyłapać szybciej się dąży ku doskonałości :D A takim cmsem joomla ma zamiar być jak mniemam. :D

socer
21-10-2005, 06:56
No myśmy ze stonem doszli do takiego wniosku że opcje smtp działają bo jak się wysyła maila z kontaktu to jest takie coś jak wyslij kopie na mój email no jak wysyłam ten list z kontaktu ze zaznaczoną opcja (wyslij kopie na mój email) to kopia dochodzi a to co najważniejsze czyli list niedochodzi ;/ (pokopane to troche ) czyli wszystko jest ok z ustawieniami smtp

vj_
21-10-2005, 16:09
Socer IP kazdego hosta sobie sprawdzasz wklepujac np. ping nazwadomeny a tutaj bedzie ping poczta.o2.pl w Start -> Uruchom -> ping poczta.o2.pl

socer
21-10-2005, 21:06
Ustawienia SMTP działają . Bo kopia jest wysyłana jak i również link aktywacyjny jest też poprawnie wysyłany ! Moze te wiadomosci z kontaktu są gdzie indziej wysyałane ?

zbuko
05-11-2005, 18:17
Hejka wsjem :) Właśnie otrzymałem maila z joomli wysłanego przez pocztę na o2. Moim skromnym zdaniem wpisanie jako hosta 'smtp.tlen.pl' + oczywiście autentykacja smtp przy użycui hasła, jest skutecznym rozwiązaniem :p Wiem, że na stronie o2 są podane inne nazwy serwerów, ale ja tak konfiguruję programy pocztowe już od lat i zawsze mi działa. BTW pingując poczta.o2.pl mam ip 193.17.41.26 i brak odpowiedzi, a smtp.tlen.pl - ip 212.126.20.60 i dwa na cztery pakiety są odbijane przez serwer :confused:

P.S. Mam nadzieję, że mój pierwszy post na tym forum okaże się pomocny :rolleyes:

gottie
08-03-2006, 01:57
Rowniez mam problem z wysylaniem maili. Joomla 1.0.8 na ovh.org. Konfiguracja poczty na SMTP, autoryzacja TAK, login, haslo, poczta.o2.pl. Ani rejestracja uzytkownikow, ani kontakty nie dzialaja... lipa :(

Czy ma ktos ustawione SMTP z jakiegos serwera ktore dziala 100%??

viper
08-03-2006, 02:11
http://forum.joomla.pl/forum/showpost.php?p=2759&postcount=17

gottie
08-03-2006, 08:47
http://forum.joomla.pl/forum/showpost.php?p=2759&postcount=17

Moje ustawienia:

http://gottie.ovh.org/poczta.JPG

Efekt: Wczoraj nic nie dzialalo, dzis zaczelo dzialac aktywowanie kont. Nadal nie dziala wysylanie maili w dziale kontakt. Kopia wiadomosci dochodzi, niestety mail nie. MAm ustawione odsylacz do uzytkownika.

stone
08-03-2006, 10:48
Wejdsz we własciwości kontaktu w panelu administacyjnym i sprawdz czy dla danego kontaktu masz przypisany adres e-mail

gottie
08-03-2006, 11:50
Wejdsz we własciwości kontaktu w panelu administacyjnym i sprawdz czy dla danego kontaktu masz przypisany adres e-mail

tak, jak pisalem wczesniej mam ustawiony odsylacz do Admina. Probowalem tez na innych uzytkownikow i nic... kopia dochodzi, mail niestety nie. :(

mij
13-05-2006, 21:40
Witam serdecznie,

Mam podobne problemy z wysyłaniem linków rejestracyjnych i potwierdzeń wiadomości do użytkowników innych niż serwer poczty dla mojej domeny.

I tak:

- Nowy użytkownik rejestrując się jeżeli poda mail'a z mojej domeny wystko jest ok. ja dostaję potwierdzenie rejestracji a on linka aktywacyjnego.

- Podobnie wygląda sprawa przy wysyłaniu wiadomości z formularza z potwierdzeniem.

- Problem zaczyna się gdy użytkownik poda adres z innej domeny np. interia, onet itp. - ja dostaje potwierdzenie a on nic ... ????

Wszelkie problemy konfiguracyjne po stronie Jooml'i pomijam bo błąd w konfiguracji skutkował by zupełnym brakiem "wysyłek".

Dodam, że sama poczta na serwerach mojego admina chodzi idealnie. Dodatkowo mam na swoim serwerze postawionego SquirrelMail, którego administrator przystosował do gadania z jego głównym SQL'em pocztowym i z poziomu php - Squirrel wysyłanie działa idealnie.

Zrobiłem jeszcze jeden test i zmieniłem hosta SMTP w Jooml'i na jakiegoś z darmowego np. poczta.interia.pl i tu także problem … nikt nic nie dostał ;-)

Domyślam się, że na serwerach na których wkupiłem „Plac” jest blokowana komunikacja SMTP z … do 25’tego portu TCP maszyn docelowych-pocztowych to by mogło wyjaśnić problemy z obcym kontem ale jeżeli na mojej poczcie użytkownicy z mojej domeny dostają potwierdzenia to gdzie jest problem ????

Czy znacie może jakiś mechanizm (raczej po stronie serwera pocztowego) który nie dopuści do wysłania maila poza domenę z wyk SMTP ??? gdyby takie coś działało był by problem z wysyłaniem mail’i np. z outlook’a. ??? a nie ma wszystko jest ok.

Może macie jakieś pomysły zanim zacznę zawracać głowę ADMINOWI. ???


Pozdrawiam

MIJU

mij
13-05-2006, 22:07
No i jak sobie człowiek napisze jaki ma problem to i mu się w głowie wszystko poukłada … i sam znajdzie rozwiązanie.

I teraz informacja dla Was …

Problem był po stronie Jooml’i - a konkretnie autoryzacji SMTP, która była włączona ale …

Użytkownika miałem wpisanego bez nazwy domeny

Jak dopisałem user@domena.pl wszystko zaczęło działać. ;-)))))


Więc do linku, który często się pojawia przy odpowiedziach na te tematy
http://forum.joomla.pl/forum/showpos...9&postcount=17 (http://showpost.php?p=2759&postcount=17)

należy dodać uwagę:


Konto SMTP: NazwaTwojegoKonta i @domena.pl (NazwaTwojegoKonta@domena.pl) - opcjonalnie



Pozdrawiam i przepraszam za zajmowanie marnowanie miejsca na forum ale może komuś to pomoże.

PS.

Dodam, że gdy startowałem z tym usługodawcą użytkownik do autoryzacji był bez domeny sprawdziłem w starych mail'ach od ADMINA. !!!!


MIJU

Guti
14-05-2006, 13:12
czesc

Pytanie co nalezy wpisac bezposrednio do pliku configuration.php przy opcji
Obsługa poczty: przez serwer smtp


$mosConfig_mailer = '?


Pisze dlatego gdyz nie moge wejsc bezposrednio w panel "konfiguracja strony" wyswietla sie pusta strona moze ktos tez wie dlaczego??

pozdrawiam

Rybik
14-05-2006, 15:11
http://www.pomoc.joomla.pl/pomoc/index.php/content/view/419/26/

Guti
14-05-2006, 15:43
Dzięki

Widzialem juz te stronkę tylko nadal nie wiem co nalezy wpisac bezposrednio do pliku configuration.php mam 3 opcje:

Funkcja mail języka PHP, program Sendmail oraz serwer SMPT

Co dokladnie nalezy wpisac aby korzystac z opcji serwer SMTP ???

magic
14-05-2006, 15:55
$mosConfig_mailer = 'smtp'; // tutaj ze maile ma obslugiwac serwer smtp

$mosConfig_smtpauth = '1'; // tutaj ze serwer smtp wymaga autoryzacji
$mosConfig_smtphost = 'smtp.smtp_host.pl'; // tutaj adres serwera smtp
$mosConfig_smtppass = 'twoje_haslo'; // tutaj twoje haslo do autoryzacji
$mosConfig_smtpuser = 'nazwa_konta'; // tutaj nazwa twojego konta na serwerze smtp

Treść do wstawienia w ostatnich 4 zmiennych zależy od wymogów na serwerze smtp na którym masz konto - znajdziesz info np. w FAQ typu: "jak ustawić parametry w kliencie poczty" na tym serwerze, albo spytaj admina.

Maker3
09-08-2006, 18:27
Czy jest możliwe wysyłanie e-maili na gmail

Przeczytałem cały temat ale nikt nie pisał o możliwości wysyłania poprzez gmail.

Chodzi mi komponent "Kontakt", bo emaile wysyłane z formularza " Napisz do nas" nigdzie nie dochodzą.

gottie
09-08-2006, 19:15
Nie jest mozliwe bo gmail uzywa innych protokolow i portow podczas wysylania niz zwykly smtp.

Maker3
09-08-2006, 19:20
Teraz mam kolejny problem.

Jak robię próby wysłania e-maila z kontaktu, to dochodzi tylko kopia.
konto w o2

pbart
10-01-2007, 19:19
witam sznownych forumowiczow, po zainstalowani joomla 1.0.12 stable, pojawil sie nastepujacy problem: przy probie rejestracji w serwisie i probie wyslania maila przez SMTP pojawia sie nastepujacy blad


Warning: Invalid argument supplied for foreach() in /home.4/c/o/r/corcordi/www/includes/frontend.php on line 94
Warning: Invalid argument supplied for foreach() in /home.4/c/o/r/corcordi/www/includes/pathway.php on line 48
Warning: array_keys() [function.array-keys]: The first argument should be an array in /home.4/c/o/r/corcordi/www/includes/pathway.php on line 63
Warning: Invalid argument supplied for foreach() in /home.4/c/o/r/corcordi/www/components/com_registration/registration.php on line 217


czy ktos z was spotkal sie z podobnym problemem ?

ebol
20-01-2007, 02:41
Witam wszystkich,

moje pytanie moze sie wydac dziwne, ale czy opcja wysylania przez smpt na najczesciej uzywanych kontach dziala na dzien dzisiejszy ? Pytam, bo mialem kilka serwisow skonfigurowanych, opartych na o2.pl i wszystko bylo ok - do czasu. Pozniej maile przestaly przychodzic.... staram sie wlasnie skofigurowac joomle, jak na razie bez skutecznie. Jakies pomysly ?

wernii
01-02-2007, 13:27
Niestety tez mam problem skonfigurowaniem formularza zeby wysylal przez SMTP. Twierdzi ze wyslanie nie jest wstanie wykonac bo nie ma wpisanego adresu email. (oczywiscie jest wszystko jak nalezy)

a wyslanie przez mailPHP mam bledy chociarz maile dociera.
ale niby jest blad:

This is the Postfix program at host web16.....

I'm sorry to have to inform you that your message could not be
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The Postfix program

<Podaj@... (http://poczta.bestgroup.pl/src/compose.php?send_to=Podaj%40web16.flexopartner.net )> (expanded from <Podaj>): unknown user: "podaj"

<sw363j@... (http://poczta.bestgroup.pl/src/compose.php?send_to=sw363j%40web16.flexopartner.ne t)> (expanded from <sw363j>): unknown user:
"sw363j"

<e-mail@... (http://poczta.bestgroup.pl/src/compose.php?send_to=e-mail%40web16.flexopartner.net)> (expanded from <e-mail>): unknown user:
"e-mail"

<adres@.... (http://poczta.bestgroup.pl/src/compose.php?send_to=adres%40web16.flexopartner.net )> (expanded from <adres>): unknown user: "adres"

bester
08-02-2007, 21:47
witka
mój pierwszy post na forum może komus pomoże
więc tak
miałem kiedyś mambo i był problem z wysyłaniem emaili okazało się że wina stala po stronie serwera nie była aktywna funkcja sendmail jak gość mi skonfigurował wszystko śmigało z wyjątkiem upload files mogłem wysłać tylko jeden plik z formularza

teraz mam joomalę 1.12 pl i nic nie chciało działać, wysyłać płatny hosting i nic,
jedynym wyjściem jest u mnie skonfigurowanie następujące
w konfiguracji poczty mam wybrane php mail, potem swoją nazwę dowolną i adres z pocztowy z onetu, ale najważniejsze jest w kontaktach na ten adres dochodzą emaile jaki jest tam ustawiony

narazie cieszę się że to się dało zrobić teraz jeszcze formularze i galeria