PDA

Zobacz pełną wersję : Problem z instalacją...



totalfree
22-01-2006, 14:00
Witam.
Oto mój problem:
Joomla! 1.0.7 PL przy każdej próbie instalacji bota, modułu lub komponentu bez względu na jego wielkość wyskakuje taki komunikat:
Fatal error: Cannot instantiate non-existent class: pclzip in /administrator/components/com_installer/installer.class.php on line 94

a tak wygląda linia 94 pliku installer.class.php
$zipfile = new PclZip( $archivename );

Instalacja z katalogu przebiega bez problemu.
Może ktoś z Was potrafi to rozwiązać.
pozdrawiam

sprawdziłem na wersji EN i tam jest wszystko ok

stone
22-01-2006, 14:32
Hmm, prosilbym o dodatkowe informacje, skad pobrana wersja, jaki to serwer i najlepiej jak wyglada php info

Gdybys nie napisal ze pod En jest ok to bym powiedzial ze sewrer nie obsluguje plikow zip, ale tak to gorzej.

totalfree
22-01-2006, 16:09
serwer wykupiony w nazwa.pl
cms PL pobrany z http://www.joomlasite.net/

Sprawdziłem również na swoim kompie używając KRASNAL Serv i jest dokładnie to samo.
temat poruszyłem równierz na innym forum.

Mowa jest o wersji 1.0.7 PL pobranej z www.joomlasite.net (http://www.joomlasite.net/) która jest całkowicie spolonizowana, bo znalazłem
jeszcze jedną polska wersję 1.0.7 PL www.joomlapl.com (http://www.joomlapl.com/) która jest nie do końca przetłumaczona i zamiast "ł" jest "?"

czy nie jest to troche dziwne że wychodzą 2 wersje "polskie" ?
może autorzy się wypowiedzą.

pozdrawiam

stone
23-01-2006, 00:11
W php info wszytsko ok, powinno dzialac. Co do dwoch wersji to jakos tak wyszlo:) Kwestia tłumaczenia panelu admina wiąże się ze zmiami w kodzie plikow, gdyz w obecnej wersji Joomli nie jest dostępne proste tłumaczenie panelu admina. W wersji 1.1. która ma być w pierwszy kwartale 2006 będzie już to poprawione i wtedy sądze ze ukaze się jedna, oficjalna wersja.

Co do Twojego problemu to ciężko mi powiedziec czemu tak się dzieje, czy na wersji z joomlapl.com tez występuje ten problem?

totalfree
23-01-2006, 12:36
W wersji ze strony joomlapl nie ma tego błędu.

Problem rozwiązałem:

W paczce z www.joomlasite.net (http://www.joomlasite.net/) w katalogu
\administrator\includes\pcl\pclzip.lib.php ma zerową wielkość
wystarczy przenieść z poprzedniej wersji ten pliczek i instalacja
spakowanych bot, mod, com działa poprawnie.

Jest jeszcze jeden mały błąd w panelu admina:
po nacisnieciu Menadżera języków zamiast wejść w opcje,
odświeża się strona :)
pozdrawiam i dzięki za odzew

stone
23-01-2006, 12:45
A to skolei wystepuje w ktorej paczce?

livio
23-01-2006, 13:35
Kiedyś jak pobrałem z joomlasite.net też miałem pełno problemów, a jak pobrałem z joomla.pl - żadnych, co najwyżej wina serwera, ale to nic...

totalfree
23-01-2006, 16:03
A to skolei wystepuje w ktorej paczce?
W paczce z www.joomlasite.net (http://www.joomlasite.net/)

ps. Autor na w/w stronie wydał już poprawiona paczkę JOOMLA 1.0.7 PL

Rybik
14-05-2006, 20:11
(keywords: zip, błąd, nazwa)
błąd:
PCLZIP_ERR_READ_OPEN_FAIL (-2)
gdzie:
wystepuje np. na nazwa.pl
ponieważ:
php 5
i co zrobić:
dopisać w .htaccess na koncu linie : SetEnv PHP_VER 4