PDA

Zobacz pełną wersję : Brak przedrostka www



tommy81
30-11-2016, 15:00
Witam, po wgraniu joomla 3.6.2 moja strona wyswietla się prawidłowo tylko bez przedrostka www , dodając przedrostek www nie wyświetla się. Dodatkowo działa tylko strona główna a podstrony się nie wyświetlają błąd 404.
Strona to pro-resovia.pl czy mogę prosić kogoś o pomoc?

Jestem początkujący dlatego proszę w miare zrozumiale:)

pkosela
30-11-2016, 15:24
Dwa problemy:
1. Przekierowanie 301
2. .htaccess w Jooomla
Myślę, że jak poczytasz o tych dwóch rzeczach, to rozwiążesz oba problemy.

tommy81
30-11-2016, 16:05
Witam a czy nie mógłbyś mi napisać co mam zrobić aby problemy rozwiązać?

zwiastun
30-11-2016, 16:45
Jestem początkujący dlatego proszę w miare zrozumiale

Witam a czy nie mógłbyś mi napisać co mam zrobić aby problemy rozwiązać?

To się tak nie da. Albo chcesz zrozumieć i zrobić, a do tego potrzebna wiedza. Albo chcesz, żeby ktoś Ci zrobił. Ale wówczas dział zleceń.

Właczenie .htaccess => przejdź do głównego katalogu joomla i zmień plik htaccess.txt na .htaccess (to jest prawdopodobnie powód błędu 404)

Gall Anonim
30-11-2016, 16:55
co mam zrobić aby problemy rozwiązać?
htaccess.txt w głównym katalogu Joomla zmienić na .htaccess
i wykonać prawidłową konfigurację
- natomiast sorki - spraw mi przyjemność i popracuj odrobinkę paluszkami na klawiaturze korzystając z google - to już było opisywane pewnie tysiące razy

tommy81
30-11-2016, 19:02
Panowie zrobiłem jak mówiliście , efekt żaden niestety , co dalej?

- - - Updated - - -

po zrobieniu przekierowania na 301 nie chodz ani z www ani bez ............. :(

maskodka
30-11-2016, 19:30
co do .htaccess Konfiguracja globalna musi byc na tak



Zastosuj przepisywanie URL [Use URL rewriting]: ustawienie Tak spowoduje wykorzystanie mechanizmu serwera zapewniającego proste adresy (przepisywanie, translację adresów) URL, o ile serwer IIS albo Apache udostępnia taki mechanizm (moduł URL Rewrite na serwerach IIS albo mod_rewrite na serwerach Apache). Ustawienie domyślne omawianego parametru: Nie, zalecane: Tak - jeśli możliwe.

Uwaga: Obok ustawienia Tak niezbędne jest jeszcze - w przypadku serwerów Apache przemianowanie znajdującego się w głównym katalogu Joomla! pliku htaccess.txt na .htaccess (z kropką na początku, bez rozszerzenia .txt), a w przypadku serwerów IIS 7 przemianowanie pliku web.config.txt na web.config. Jeśli nie rozumiesz budowy i działania tych plików, nie dokonuj w nim żadnych samodzielnych modyfikacji. Pliki te dostarczane w pakiecie instalacyjnym Joomla! są już odpowiednio przygotowane. Wystarczy je tylko przemianować.

http://wiki.joomla.pl/Pomoc35:System_Konfiguracja_globalna

Czytanie nie boli :)
https://extensions.joomla.org/extension/airedirectwww

tommy81
30-11-2016, 20:00
maskodka , dzięki za odpowiedź . Z dwóch niewiadomych została jedna. Mianowicie zastosowanie przepisywania url dało pojawianie się podstron a więc znikniecie błędu 404 . Drugi problem pozostał czyli strona reaguje tylko na pro-resovia.pl na www.pro-resovia.pl nie reaguje . .htaccess i web.config zmodyfikowane. Konfiguracja globalna : Proste Adresy tak,Zastosuj przepisywanie url tak, adresy z przyrostkiem nie, aliasy w unikodzie nie, nazwa witryny do tytułów stron nie. Jak zrobić zeby było to www. ?

maskodka
30-11-2016, 20:15
pytanie jak masz ustawiona domene na hosting za pomocą dns ? i gdzie masz domene a gdzue hosting? ?

tommy81
30-11-2016, 20:41
domene i hosting mam na az.pl

- - - Updated - - -

"Zarządzaj rekordami DNS dla pro-resovia.pl" skopiowałem czyli za pomocą dns chyba :)

maskodka
30-11-2016, 20:54
kiedy podpiąłeś domenę zachowanie twojej domeny sugeruje złe podpięcie po stronie hostingu

zmieniałeś coś htaccess?

popros admina serwera opisz sprawę

Pecetowicz
30-11-2016, 21:43
Pokaż twoją zawartość pliku htaccess. Pamiętaj też o ustawieniu odpowiedniego przedrostka w Google Webmaster Tools aby nie było problemów z pozycją..

tommy81
30-11-2016, 22:27
##
# @package Joomla
# @copyright Copyright (C) 2005 - 2016 Open Source Matters. All rights reserved.
# @license GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line 'Options +FollowSymLinks' may cause problems with some server configurations.
# It is required for the use of mod_rewrite, but it may have already been set by your
# server administrator in a way that disallows changing it in this .htaccess file.
# If using it causes your site to produce an error, comment it out (add # to the
# beginning of the line), reload your site in your browser and test your sef urls. If
# they work, then it has been set by your server administrator and you do not need to
# set it here.
##

## No directory listings
IndexIgnore *

## Can be commented out if causes errors, see notes above.
Options +FollowSymlinks
Options -Indexes

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site then comment out the operations listed
# below by adding a # to the beginning of the line.
# This attempts to block the most common type of exploit `attempts` on Joomla!
#
# Block any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block any script that includes a ********** tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment the following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.

- - - Updated - - -

i jak ??

tommy81
01-12-2016, 18:55
Dzięki za pomoc "maskodka" podstrony działają po jego uwadze:) co do przedrostka www wina była po stronie geniuszy z AZ.pl , już wszystko smiga , dzięki za pomoc wszystkim:) Temat do zamknięcia