PDA

Zobacz pełną wersję : Problem z aktualizacją Joomli



Raitxxl
28-06-2022, 21:50
Witam serdecznie. Otóż mam za zadanie zaktualizować Joomle z wersji 3.10.10 do wersji 4.1 jednak po aktualizacji pojawiają się następujące błędy no głównej stronie:
https://prnt.sc/oijjivDUD-Ou
Z kolei front end nawet nie posiada opcji logowania:
https://prnt.sc/kLrkfnvCpH1o

Prosiłbym o możliwie proste wytłumaczenie. Z góry dziękuje i pozdrawiam.

terra
29-06-2022, 08:43
Najprościej - używany szablon jest niezgodny z wersją 4.
Szablon z wersji 3.x nie będzie działał poprawnie na wersji 4.x

Raitxxl
29-06-2022, 13:54
Teraz pokazuje mi się taki błąd:
Call to undefined method Joomla\Database\Mysqli\MysqliDriver::getErrorNum()
oraz takie błędy na frontend:
https://prnt.sc/aWiXtP6i4zIh
https://prnt.sc/Gu7juLSEeGBP
oraz takie informacje na back-end:
https://prnt.sc/VuegdM7LoofP

Czy jest to spowodowane starszą wersją bazy danych?
Z góry dziękuje za odpowiedź i pozdrawiam.

terra
29-06-2022, 16:39
wykonałeś migrację przed sprawdzeniem zgodności dodatków i szablonu, więc pojawiają się błędy framework'a Joomla. Odtwórz z kopii poprednią wersję strony. Zacznij od początku, najpierw zweryfikuj zgodność, wyłącz wszystkie niezgodne rozszerzenia , szablony, dodatki i dopiero migruj.

minkycm
26-06-2023, 12:24
Teraz pokazuje mi się taki błąd:
Call to undefined method Joomla\Database\Mysqli\MysqliDriver::getErrorNum()
oraz takie błędy na frontend:
https:// (http://prnt.sc/aWiXtP6i4zIh)www (https://skylap.pl).prnt.sc/aWiXtP6i4zIh (http://prnt.sc/aWiXtP6i4zIh)
https://prnt.sc/Gu7juLSEeGBP
oraz takie informacje na back-end:
https://prnt.sc/VuegdM7LoofP

Czy jest to spowodowane starszą wersją bazy danych?
Z góry dziękuje za odpowiedź i pozdrawiam.

Dokładnie tak, jako początkujący popełniłem ten sam błąd.

terra
26-06-2023, 13:35
To nie baza, tylko komponent uniterevolution2 powoduje błąd bazy, czyli slider, który jest dla Joomla3, więc jeśli masz J4 to nie ma prawa działać.