PDA

Zobacz pełną wersję : Aktualizacja PHP w Joomla 4.3.4



kazimierzbanhajer
26-08-2023, 13:33
Dostałem info: Twoja wersja PHP, 8.0.29, w tej chwili otrzymuje tylko poprawki zabezpieczeń. Oznacza to, że już wkrótce nie będzie ona obsługiwana. Zaleca się zaplanowanie uaktualnienia do nowszej wersji PHP, zanim aktualnie używana osiągnie koniec wsparcia z datą 26-11-2023. Uaktualnienie do nowszej wersji (zalecana jest wersja 7.x) spowoduje, iż Joomla będzie działać szybciej i zwiększy się bezpieczeństwo jej użytkowania. Skontaktuj się ze swoją firmą hostingową aby uzyskać informacje jak dokonać aktualizacji.
Co mam zrobić. Najnowsza wersja PHP u mnie to 8.2 a tu pisze żeby aktualizować do 7.x. Co zrobić?

rkonik
26-08-2023, 22:33
Błąd tłumaczenia :) Podoba mi się to tłumaczenie :) Prawdopodobnie osoby od polskiej wersji językowej zapomnieli poprawić ten błąd.
Musisz zaktualizować do wyższej wersji. Najlepiej do najwyższej ale niektóre rozszerzenia mogą powodować błędy więc sprawdź u dostawców rozszerzeń z jakimi wersjami możesz współpracować.
Cykl życia PHP znajdziesz pod tym linkiem: https://www.php.net/supported-versions.php

pablop76
26-08-2023, 23:23
rkonik chyba nie doczytał do końca pytania. Ja mam to samo, i też jestem ciekaw jak się rozwinie sytuacja. Na razie czekam. To tylko info.

rkonik
27-08-2023, 01:10
Tłumaczenie dotyczy stałej PLG_QUICKICON_PHPVERSIONCHECK_SECURITY_ONLY

Oryginał w w j. angielskim brzmi:

Your PHP version, %1$s, is only receiving security fixes from the PHP project at this time. This means your PHP version will soon no longer be supported. We recommend planning to upgrade to a newer PHP version before it reaches end of support on %2$s. Joomla will be faster and more secure if you upgrade to a newer PHP version. Please contact your host for upgrade instructions.

Jest błąd w tłumaczenia. Zespół od tłumaczeń dodał od siebie fragment (zalecana jest wersja 7.x) i tyle.

pablop76
27-08-2023, 03:03
No ale mamy wersje php >= 8.0 to skąd ten komunikat? Nie chodzi o tłumaczenie.

Bazyl
27-08-2023, 10:34
Twoja wersja PHP, 8.0.29, w tej chwili otrzymuje tylko poprawki zabezpieczeń.

Otworzyłeś link, który podesłał @rkonik?

pablop76
27-08-2023, 11:56
Autor ma wersję 8.2

rkonik
27-08-2023, 12:08
Najnowsza wersja PHP u mnie to 8.2 a tu pisze żeby aktualizować do 7.x. Co zrobić?
Wystarczy czytać ze zrozumieniem. To taka umiejętność której uczą w podstawówce. Autora wprowadza w błąd informacja że jego wersja PHP, 8.0.29, która jest podana w komunikacie właśnie dostała wyłącznie wsparcie dla zabezpieczeń. Żywotność tej wersji się zakończyła i nie będzie rozwijana dlatego należy ją zmienić na nowszą. Autor najnowszą wersję na hostingu ma 8.2 a w komunikacie ze względu na niewłaściwe tłumaczenie a w zasadzie dodanie od siebie przez zespół tłumaczący informacji o tym aby wybrał jakąś wersję 7.x To wprowadziło autora w błąd. Zakładam że nie jedną osobę. Jest to błąd tłumaczenia. Dlatego dałem Ci oryginalny tekst abyś widział jak wygląda prawdziwy komunikat. Dodatkowo podałem link do cyklów życia PHP aby łatwiej było podjąć decyzję.

terra
27-08-2023, 14:35
Co tu pisać, to ewidentnie błąd edytorski. minimalna zalecana wersja dla J4 to 7.2 i o to w tym wszystkim chodzi :), natomiast max. zalecana to 8.0, jesli masz 8.1 lub wyższą to może być problem. Dopiero następna wersja to min.8.1

zwiastun
27-08-2023, 15:19
Komunikat powinien brzmieć:
Twoja wersja PHP, [tu numer wykrytej wersji], otrzymuje obecnie od projektu PHP tylko poprawki bezpieczeństwa. Oznacza to, że Twoja wersja PHP wkrótce przestanie być wspierana. Zalecamy zaplanowanie aktualizacji do nowszej wersji PHP, zanim [tu data, w której posiadana wersja ] osiągnie koniec wsparcia. Uaktualnienie do nowszej wersji spowoduje, iż Joomla będzie działać szybciej i zwiększy się bezpieczeństwo jej użytkowania. Skontaktuj się ze swoją firmą hostingową, aby uzyskać informacje, jak dokonać aktualizacji.