SMF + Mambo 4.5.2
Wyniki 1 do 4 z 4

Temat: SMF + Mambo 4.5.2

  1. #1
    Nowicjusz
    Dołączył
    09-11-2005
    Wpisy
    23
    Punkty
    16

    Domyślny SMF + Mambo 4.5.2

    Witam pobrałem sobie z tej strony: http://mamboforge.net/frs/?group_id=543 plik MOS_SMF_BRIDGEv3.19a_stable.zip i zaczełem integrację. Integracja składa się z 4 punktów. Pierwsze 3 punkty wykonałem poprawnie, ale zatrzymałem się na czwartm, który brzmi tak:

    Step 4 - Installing the Login Module in Mambo

    a) Install mod_smf_login.php as a module.

    b) Go to your Mambo template (index.php), and add the following code, right before the </head> tag:

    <?php
    global $sc, $context;

    if (!defined('SMF')){
    require ("administrator/components/com_smf/config.smf.php");
    require ($smf_path."/SSI.php");
    }

    $sc = &$context['session_id'];
    $_SESSION['USER_AGENT'] = $_SERVER['HTTP_USER_AGENT'];

    mysql_select_db($mosConfig_db);
    ?>

    c) Also, in your mambo template (index.php), add the following code just above the </body> tag:

    <?php mysql_select_db($db_name); ?>

    d) Publish the module, and unpublish the default Mambo login module.
    A wykonuję go w taki sposób: otwieram plik index.php z mojej templatki i przed </head> umieszczam:

    Kod:
    <?php
        global $sc, $context;
    
        if (!defined('SMF'))
        {
             require ("administrator/components/com_smf/config.smf.php");
             require ($smf_path."/SSI.php");
        }
    
        $sc = &$context['session_id'];
        $_SESSION['USER_AGENT'] = $_SERVER['HTTP_USER_AGENT'];
    
        mysql_select_db($mosConfig_db);
    ?>
    oraz przed </body> umieszczam:
    Kod:
    <?php mysql_select_db($db_name); ?>
    I teraz gdy wchodzę na strone mam białą strone a na niej błąd:

    Warning: main() [function.main]: open_basedir restriction in effect. File(/SSI.php) is not within the allowed path(s): (/home/site:/home/www:/usr/share/php) in /home/site/10895/www/templates/zwiast_email/index.php on line 70

    Warning: main(/SSI.php) [function.main]: failed to open stream: Operation not permitted in /home/site/10895/www/templates/zwiast_email/index.php on line 70

    Warning: main() [function.main]: open_basedir restriction in effect. File(/SSI.php) is not within the allowed path(s): (/home/site:/home/www:/usr/share/php) in /home/site/10895/www/templates/zwiast_email/index.php on line 70

    Warning: main(/SSI.php) [function.main]: failed to open stream: Operation not permitted in /home/site/10895/www/templates/zwiast_email/index.php on line 70

    Fatal error: main() [function.require]: Failed op
    W czym może być problem?
    Ostanio edytowane przez pirex : 11-11-2005 15:23

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Wyjadacz josh awatar
    Dołączył
    20-09-2005
    Skąd
    B-stock :)
    Wpisy
    513
    Punkty
    86

    Domyślny

    Witam

    proponuje do integracji uzyc komponentu JoomlaSMFForum 1.0.2 PL
    bedzie duzo prosciej

    pozdr
    pozdrawiam
    Piotr Laskowski
    JoomlaPL.com | MamboPL.com
    Joomla.PL | Joomla!, LaTeX, R project, SPSS user...

  4. #3
    Nowicjusz
    Dołączył
    09-11-2005
    Wpisy
    23
    Punkty
    16

    Domyślny

    No tak, ale on działa tylko z SMF 1.1 - a ja mam 1.5 - to zainstaluje wersje JoomlaSMFForum 1.0.1 PL - ale czym ona się różni od 1.0.2?
    Ostanio edytowane przez pirex : 11-11-2005 18:19

  5. #4
    Wyjadacz josh awatar
    Dołączył
    20-09-2005
    Skąd
    B-stock :)
    Wpisy
    513
    Punkty
    86

    Domyślny

    musialbys zobaczyc ktora wersja dziala z 1.05 na pewno znajdziesz taka na mambopl.com, a co nowego w wyzszych wersjach? a poprawione bledy znalezione w poprzednich

    pozdr
    pozdrawiam
    Piotr Laskowski
    JoomlaPL.com | MamboPL.com
    Joomla.PL | Joomla!, LaTeX, R project, SPSS user...

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •