Bląd przy instalacji
Wyniki 1 do 7 z 7

Temat: Bląd przy instalacji

  1. #1
    Debiutant
    Dołączył
    04-11-2008
    Wpisy
    4
    Punkty
    10

    Domyślny Bląd przy instalacji

    Witam! Probuje zainstalowac Joomla! PE 1.0.15a i niestety przy instalacji wyrzuca mi taki blad:

    SQL=Something is wrong in your syntax obok \'CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
    \n PRIMARY KEY (\' w linii 6 SQL=CREATE TABLE IF NOT EXISTS `jos_zoom_comments` (
    \n `cmtid` int(11) NOT NULL auto_increment,
    \n `imgid` int(11) NOT NULL default \'0\',
    \n `cmtname` varchar(40) NOT NULL default \'\',
    \n `cmtcontent` text NOT NULL,
    \n `cmtdate` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
    \n PRIMARY KEY (`cmtid`),
    \n KEY `imgid` (`imgid`)
    \n) TYPE=MyISAM AUTO_INCREMENT=1:
    - - - - - - - - - -
    CREATE TABLE IF NOT EXISTS `#__zoom_comments` (
    `cmtid` int(11) NOT NULL auto_increment,
    `imgid` int(11) NOT NULL default '0',
    `cmtname` varchar(40) NOT NULL default '',
    `cmtcontent` text NOT NULL,
    `cmtdate` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
    PRIMARY KEY (`cmtid`),
    KEY `imgid` (`imgid`)
    ) TYPE=MyISAM AUTO_INCREMENT=1
    = = = = = = = = = =

    Przy instalacji wybralem full opcje. Dopiero zaczynam zabawe z Joomla!. Dodam ze wczesniej mialem zainstalowana inne wersje Joomla! (nowsze i starsze) i za kazdym razem instalacja odbywala sie bezproblemowo, a tu taki zonk . Moze ktos poradzi jak mam rozwiazac ten problem?
    Dzieki.
    Ostanio edytowane przez kojot77 : 04-11-2008 03:46

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    27 287
    Punkty
    1132

    Domyślny

    Prawdopodobnie masz starszą wersję MySQL-a
    Spróbuj podmienić kwerendę w pliku zoom.xml
    DROP TABLE IF EXISTS `jos_zoom_comments`;
    CREATE TABLE IF NOT EXISTS `jos_zoom_comments` (
    `cmtid` int(11) NOT NULL auto_increment,
    `imgid` int(11) NOT NULL default '0',
    `cmtname` varchar(40) NOT NULL default '',
    `cmtcontent` text NOT NULL,
    `cmtdate` timestamp NOT NULL default '',
    PRIMARY KEY (`cmtid`),
    KEY `imgid` (`imgid`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=1 ;
    Korzystaj i ciesz się!
    ===============
    Zwiastun
    Biblioteka Elektronicznej Dokumentacji Joomla!

  4. #3
    Debiutant
    Dołączył
    04-11-2008
    Wpisy
    4
    Punkty
    10

    Domyślny

    Dzieki za pomoc, ale niestety nie do konca pomoglo, teraz sie czepia dalej:

    SQL=Something is wrong in your syntax obok \'ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=1\' w linii 9 SQL=CREATE TABLE IF NOT EXISTS `jos_zoom_comments` (
    \n`cmtid` int(11) NOT NULL auto_increment,
    \n`imgid` int(11) NOT NULL default \'0\',
    \n`cmtname` varchar(40) NOT NULL default \'\',
    \n`cmtcontent` text NOT NULL,
    \n`cmtdate` timestamp NOT NULL default \'\',
    \nPRIMARY KEY (`cmtid`),
    \nKEY `imgid` (`imgid`)
    \n) ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=1:
    - - - - - - - - - -
    CREATE TABLE IF NOT EXISTS `jos_zoom_comments` (
    `cmtid` int(11) NOT NULL auto_increment,
    `imgid` int(11) NOT NULL default '0',
    `cmtname` varchar(40) NOT NULL default '',
    `cmtcontent` text NOT NULL,
    `cmtdate` timestamp NOT NULL default '',
    PRIMARY KEY (`cmtid`),
    KEY `imgid` (`imgid`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=1
    = = = = = = = = = =

    pozdrawiam i licze na dalsze wskazowki

  5. #4
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    27 287
    Punkty
    1132

    Domyślny

    A możesz z łaski swojej podac pznajmniejpodstawowe dane o swoim środowisku?
    Korzystaj i ciesz się!
    ===============
    Zwiastun
    Biblioteka Elektronicznej Dokumentacji Joomla!

  6. #5
    Debiutant
    Dołączył
    04-11-2008
    Wpisy
    4
    Punkty
    10

    Domyślny

    Przepraszam, juz podaje:
    WinXP SP3 oraz Krasnal 2.7-5 w sklad ktorego wchodza:

    Apache 1.3.31
    PHP 4.3.9
    PHP 5.0.2 (ten uruchomiony)
    MySQL 3.23.58
    ActivePerl 5.6.1.628
    phpMyAdmin 2.6.0 pl2
    SQLiteManager 1.0.1
    CesarFTP 0.99g
    WebAlizer 2.1
    Free SMTP Server

  7. #6
    Debiutant
    Dołączył
    04-11-2008
    Wpisy
    4
    Punkty
    10

    Domyślny

    Juz jest ok, zainstalowalem mysql 4.1.11 i poszlo na tych ustawieniach co podales, dzieki wielkie. Probowalem zmienic na orginalne ale byl ten sam blad.

    Pozdroofka

  8. #7
    Debiutant
    Dołączył
    01-02-2009
    Wpisy
    1
    Punkty
    10

    Domyślny

    WITAM.JA mam podobny problem wyświetla mi
    DROP TABLE IF EXISTS `jos_zoom_comments`;
    CREATE TABLE IF NOT EXISTS `jos_zoom_comments` (
    `cmtid` int(11) NOT NULL auto_increment,
    `imgid` int(11) NOT NULL default '0',
    `cmtname` varchar(40) NOT NULL default '',
    `cmtcontent` text NOT NULL,
    `cmtdate` timestamp NOT NULL default '',
    PRIMARY KEY (`cmtid`),
    KEY `imgid` (`imgid`)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=1 ;
    i nie wiem co zrobić...
    uzywam MySQL 4.0 oraz PhP 5


    pomoże ktoś?

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •