Wyniki 1 do 9 z 9

Temat: Ostrzeżenia w 1 kroku instalacji nowej wersji joomli 2.5.14 w środowisku xampp!

  1. #1
    Przeglądacz
    Dołączył
    05-10-2012
    Skąd
    Birmingham, UK
    Wpisy
    93
    Punkty
    7

    Domyślny Ostrzeżenia w 1 kroku instalacji nowej wersji joomli 2.5.14 w środowisku xampp!

    Ostrzeżenia przy instalacji joomla 2.5.14 na xampp!!!


    Warning: Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in C:\xampp\htdocs\agencja\libraries\joomla\filter\in put.php on line 652
    Warning: Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in C:\xampp\htdocs\agencja\libraries\joomla\filter\in put.php on line 654


    Jeszcze nie zaczałem instalować joomli, a już dostaję dziwne komunikaty.

    Uwaga; Mam najnowszą wersję xampp 1.8.3.1 z najnowsza wersją PHP 5.5.3!

    Co jest złe, nowa wersja joomli czy może xampp? Czy można jakoś to naprawić? Proszę o pomoc. Dziękuję z góry

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Bywalec
    Dołączył
    11-03-2009
    Skąd
    Kraków
    Wpisy
    148
    Punkty
    28

    Domyślny

    Witam bledy to raczej sa ostrzeżenia mówiące o "przestarzałej funkcji preg_replace. Zainstaluj starsza wersję XAMPP lub Mo.Vamp lub JAMP.
    ndspoland.o12.pl - obecnie w fazie tworzenia.

  4. #3
    Przeglądacz
    Dołączył
    05-10-2012
    Skąd
    Birmingham, UK
    Wpisy
    93
    Punkty
    7

    Domyślny

    Dziękuję za pomoc. Przetestuję nową joomlę na tych wymienionych innych środowiskach php i jeśli się okaże, że dobrze działa, tzn, że nowa wersja xampp wywala te ostrzeżenia.

  5. #4
    Przeglądacz
    Dołączył
    05-10-2012
    Skąd
    Birmingham, UK
    Wpisy
    93
    Punkty
    7

    Domyślny

    Znalazłem rozwiązanie, niepotrzebne jest instalowanie starszej wersji xampp. Ostrzeżenia znikną, gdy zastosuje się następującą procedurę:
    W pliku input.php w ściezce; libraries/joomla/filter/input.php w liniach 656 i 659 dokona się zmieny kodu:
    Zamiast linii $source = preg_replace('/&#(\d+);/me', "utf8_encode(chr(\\1))", $source); // decimal notation, wstawi się
    $source = preg_replace_callback('/&#(\d+);/m',
    function($matches) {
    return utf8_encode(chr($matches[0]));
    },
    $source); //widać usunięcie litery "e" z opcji /me, wstawienie funkcji zamiast środkowego argumentu oraz zastosowanie callback
    oraz pod // Convert hex zamiast $source = preg_replace('/&#x([a-f0-9]+);/mei', "utf8_encode(chr(0x\\1))", $source); // hex notation, wstawić:
    $source = preg_replace_callback('/&#x([a-f0-9]+);/mi',
    function($matches) {
    return utf8_encode(chr('0x'.$matches[0]));
    },
    $source);

    Pełny opis w poście: http://forum.joomla.org/viewtopic.php?f=707&t=821694

  6. #5
    Przeglądacz
    Dołączył
    05-10-2012
    Skąd
    Birmingham, UK
    Wpisy
    93
    Punkty
    7

    Domyślny

    Zainstalowałem do końca najnowsza wersję joomli i pracuje jak na razie dobrze w najnowszym xampp

  7. #6
    Furst
    Gość

    Domyślny

    rysiek bomba thx

  8. #7
    Przeglądacz
    Dołączył
    05-10-2012
    Skąd
    Birmingham, UK
    Wpisy
    93
    Punkty
    7

    Domyślny

    Tak kolego, ale zauważ, że mój wpis był w październiku ubiegłego roku i od tego mogło wiele się zmienić.

  9. #8
    Wiarus mjmartino awatar
    Dołączył
    03-12-2007
    Skąd
    Będzin /k Katowic
    Wpisy
    2 611
    Punkty
    193

    Domyślny

    Na xamppie działa J2.5 jak i J3.3 bez problemów
    Site building progress ... 35% never end
    ================================
    A może tak zamiast punkt w podzięce paypal

    Blog, Administracja Joomla, Video kursy z poradami Joomla. => https://mjmartino.eu
    Recenzje filmów oraz seriali => https://cobejrzec.pl

  10. #9
    Debiutant
    Dołączył
    02-01-2017
    Wpisy
    4
    Punkty
    2

    Domyślny

    Witam serdecznie, mam problem z wyświetlającym się komunikatem "Infinite loop detected in JErrorInfinite loop detected in JError", mam najnowszą wersję Xampa, niestety w linii libraries/joomla/filter/input.php w liniach 656 i 659 nie mam takich wpisów ja te powyżej mam jedynie wpis w linii 1167 $source = preg_replace_callback('/&#x([a-f0-9]+);/mi'" i tu zmiany wprowadziłem. ale na nic sie nie zdały, a błąd wyświetla się nadal.

    Na chwilę obecną wykorzystałem znane mi pomysły.

    Co zrobić żeby uruchomić stronkę...? Dziękuję za pomoc.

Podobne tematy

  1. Dwa błedy przy instalacji joomla 2.5.14 na xampp
    przez bartek1981 na forum Instalacja, aktualizacja, migracje
    Odpowiedzi: 8
    Ostatni post/autor: 02-10-2013, 20:29
  2. Błąd podczas próby instalacji joomli na XAMPP
    przez saper190 na forum Instalacja, aktualizacja, migracje
    Odpowiedzi: 2
    Ostatni post/autor: 13-10-2012, 07:55
  3. Xampp nie obsluguje localhosta w wersji 1.7.2 ?
    przez freesamen na forum Instalacja, aktualizacja, migracje
    Odpowiedzi: 3
    Ostatni post/autor: 02-11-2011, 01:42
  4. update z 1.0 do nowej wersji
    przez mysz510 na forum Instalacja, aktualizacja, migracje
    Odpowiedzi: 1
    Ostatni post/autor: 27-05-2010, 16:26
  5. Sposób utworzenia nowej wersji strony
    przez italiano na forum Instalacja, aktualizacja, migracje
    Odpowiedzi: 3
    Ostatni post/autor: 24-11-2009, 19:50

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •