Wyniki 1 do 5 z 5

Temat: Import bazy danych z PHP Version 5.5.12 do PHP 5.4

  1. #1
    Debiutant
    Dołączył
    02-02-2014
    Wpisy
    6
    Punkty
    2

    Domyślny Import bazy danych z PHP Version 5.5.12 do PHP 5.4

    Witam
    Mam problem z importem bazy danych, próbowałem różnych sposobów, ale nic nie pomaga, nie mogę "zmusić" PHPMyAdmin do zaimportowania bazy na lokalny serwer.
    Nie wiem czy problemem niue jest wersja PHP, na serwerze jest PHP Version 5.5.12-0+tld2 a JAMP ma 5.4, czy to może być przyczyną?

    Pozdrawiam
    Jacek

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2

  4. #3
    Debiutant
    Dołączył
    02-02-2014
    Wpisy
    6
    Punkty
    2

    Domyślny

    Nie wiem co ma (może) mieć wspólnego, ale szukam już wszystkich rozwiązań, bo robię imprt baz innej strony (inny serwer, PHP 5,3) i wszystko hula. Jak robię z tego serwera na którym jest 5.5, to nie da rady, czego bym nie próbował. Baza jest ok. 30 MB (PHPMyAdmin) to jest strona postawiona na Joomli. DELIMITER $$ -- -- Procedury -- CREATE DEFINER=`admin1292_joomla`@`%` PROCEDURE `jos_TeraWurfl_FallBackDevices`(current_fall_back VARCHAR(64)) BEGIN WHILE current_fall_back != 'root' DO SELECT capabilities FROM jos_TeraWurflMerge WHERE deviceID = current_fall_back; SELECT fall_back FROM jos_TeraWurflMerge WHERE deviceID = current_fall_back INTO current_fall_back; END WHILE; END$$ MySQL zwrócił komunikat: Dokumentacja #1548 - Cannot load from mysql.proc. The table is probably corrupted Dzieje się tak bez względu na format czy ustawieniu rodzaju zgodności baz.

  5. #4
    Wyga Jola awatar
    Dołączył
    08-01-2008
    Skąd
    Wrocław
    Wpisy
    3 170
    Punkty
    378

    Domyślny

    Podczas importu pomiń Procedury.
    Procedury są ściśle przypisane do bazy danych (poprzedniej nazwy bazy danych) i jak widać mają inny DELIMITER.
    Procedurę przenieś osobno usuwając DEFINER=`admin1292_joomla`@`%`

  6. #5
    Debiutant
    Dołączył
    02-02-2014
    Wpisy
    6
    Punkty
    2

    Domyślny

    Wielkie, ale to wielkie dzięki , faktycznie problem był z procedurami, czasami mamy coś przed oczami a nie widzimy, na szczęście są ludzie którzy pomogą bezinteresownie.

Podobne tematy

  1. sigplus requires PHP version 5.1 or later.
    przez darewnoo na forum Administracja - ogólne
    Odpowiedzi: 7
    Ostatni post/autor: 28-04-2011, 15:09
  2. Import bazy danych
    przez mbx na forum VirtueMart
    Odpowiedzi: 8
    Ostatni post/autor: 24-10-2008, 15:57
  3. Aktualizacja bazy danych do PHP 5
    przez strategist na forum Administracja Joomla!
    Odpowiedzi: 9
    Ostatni post/autor: 01-09-2008, 21:04
  4. Błąd includes/joomla.php on line 71 / version.php
    przez MemfiS na forum Instalacje (Joomla!, składników)
    Odpowiedzi: 10
    Ostatni post/autor: 29-07-2007, 15:18

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •