Wyniki 1 do 2 z 2

Temat: Znaki zapytania zamiast polskich znaków z wyjątkiem ó - mambo 4.5.5

  1. #1
    Nowicjusz
    Dołączył
    16-10-2009
    Wpisy
    11
    Punkty
    10

    Domyślny Znaki zapytania zamiast polskich znaków z wyjątkiem ó - mambo 4.5.5

    Nie wiedziałem gdzie napisać, jeżeli ktoś wie gdzie przenieść - poproszę.
    Gotowa jest nowa strona, w celu zabezpieczenia starej strony zrobionej w mambo 4.5.5 został lokalnie zainstalowany WAMP 2.0 z PHP 5.2.17. Baza wyeksportowana, metoda porównywania napisów jak w oryginale latin2_general_ci.
    Zainstalowana świeża wersja mambo, uzupełniona o brakujące templatki moduły boty i zdjęcia. Odpalam wszystko pięknie działa brak jednak polskich znaków jest ó ale zamiast pozostałych jest ?.
    Przekopałem wszystkie fora i wszędzie jest o innych cms-ach ale nic o starej mambo. Wydaje mi się że problem dotyczy wamp-a, phpmyadmin właściwie wyświetla zawartość bazy. W joomli jest database.php i tam (set names ) w mambo tego nie ma. Ma ktoś jakiś pomysł, głowię się już nad tym kilka dni. w templatce nie zmieniałem ustawione jak w oryginale.
    <meta http-equiv="Content-Type" content="text/html; <?php echo _ISO; ?>" />

    Grzebałem w php.ini, httpd.conf, my.ini, zupełny brak pomysłów.
    pomocy.

  2. #2
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    26 695
    Punkty
    1087

    Domyślny

    Musiałbyś odgrzebać na forum bardzo stare wpisy dotyczące problemów ze znakami. Ja już, niestety, nie pamiętam (minęło 12 lat), ale opisywałem problem. Wymaga zmiany bodaj w pliku database.php, ale niekoniecznie dobrze pamiętam. Możesz również podniś to do wersji Joomla 1.0.15 (JIE - Joomla Intternational Edition) która miała zrobione kodowanie w UTF-

    Ponadto: Rozważ, czy pozostawiać tak starą wersję - nowsze PHP jej nie obsłuży, a starsze to ryzyko włąmania.. Możliwe jest przecież przekonwertowanie tej starej witryny na stronę statyczną.

    Uważaj, żeby nie zepsuć tej bazy. Zrób kopii ze dwie na wszelki wypadek

Podobne tematy

  1. Phoca pdf znaki zapytania zamiast polskich znaków
    przez ulgroup na forum Rozszerzenia - problemy z obsługą, zarządzaniem
    Odpowiedzi: 1
    Ostatni post/autor: 05-11-2012, 15:45
  2. Brak pozycji dla modułów z wyjątkiem 'left'
    przez jerzyszczur na forum Szablony, wygląd, formatowanie
    Odpowiedzi: 2
    Ostatni post/autor: 17-04-2008, 10:41
  3. Moduł na wszystkich stronach z wyjątkiem startowej
    przez maslow_info na forum Administracja Joomla!
    Odpowiedzi: 3
    Ostatni post/autor: 11-12-2007, 17:06
  4. Znaki zapytania zamiast polskich liter
    przez n-sane na forum Instalacje (Joomla!, składników)
    Odpowiedzi: 2
    Ostatni post/autor: 25-04-2007, 13:01
  5. Tytuły pozycji w metadanych - z wyjątkiem strony głównej
    przez snowjedrzej na forum Administracja Joomla!
    Odpowiedzi: 0
    Ostatni post/autor: 26-11-2006, 18:54

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •