Bcrypt - problem z zalogowaniem do panelu administratora
Wyniki 1 do 3 z 3

Temat: Bcrypt - problem z zalogowaniem do panelu administratora

  1. #1
    Przeglądacz
    Dołączył
    21-03-2007
    Wpisy
    75
    Punkty
    10

    Joomla! 3.6 Bcrypt - problem z zalogowaniem do panelu administratora

    Witam

    Integrowałem autoryzację użytkowników Joomla poprzez Facebooka za pomocą modułu Login with social networks https://extensions.joomla.org/extens...cial-networks/

    Po 12h nie mogę zalogować się do panelu administratora.
    W PHPMyAdmin zmieniłem hasło na zabezpieczone metoda bcrypt (przy pomocy generatorów online), ale joomla dodaje pewnie swoją sól.

    I teraz efekt jest taki, że nie mam dostępu do Panelu Administratora - nie loguje się, nie wyświetla żadnej informacji, wpisuje login i hasło i znowu prosi o login i hasło. Oczywiście wysyłanie przypomnienia hasła nie działa (konto super admin)
    Czy ktoś ma może jakiś pomysł?

    Jeśli podałem za mało danych proszę o informację jakie jeszcze podać?

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Bywalec
    Dołączył
    21-03-2017
    Wpisy
    153
    Punkty
    42

    Domyślny

    Jeżeli nie masz ostrzeżenia o nieprawidłowym loginie, haśle lub braku konta, to spróbuj wyłączyć plugin/moduł w bazie danych (tabela __extensions).

    Czy ten dodatek zmienia sposób przechowywania haseł? Jeśli nie, to wystarczy MD5 bez salta (z poziomu phpMyAdmin w tabeli __users w kolumnie password wpisujesz hasło w sposób jawny, w funkcja wybierasz MD5 i zapisujesz zmiany)

    A.
    Pomogłem? Kliknij: Pomógł - daj punkt. Dzięki!

  4. #3
    Przeglądacz
    Dołączył
    21-03-2007
    Wpisy
    75
    Punkty
    10

    Domyślny

    W tabela_extensions wiersz plg_authentication_socialnetworks oraz plg_user_socialnetworks zmieniłem komórkę enable z 1 na 0.
    Hasło użytkownika zmieniłem za pomocą kodowania MD5.

    Dalej to samo.
    Dodatek nie zmienia sposobu przechowywania haseł.
    Wczoraj gdy działało dla testów zalogowałem się za pomocą konta z facebooka, w tabeli mam hasło dla tego konta zaczynające się od $2y$10$

    - - - Updated - - -

    Zmieniłem wiersz plg_authentication_joomla komórkę enable z 0 na 1 i udało się zalogować.
    Dzięki bardzo adam.lachutza pomoc

Podobne tematy

  1. Problem z zalogowaniem z panelu administratora
    przez T.O.M.M.Y na forum Rozszerzenia - problemy z obsługą, zarządzaniem
    Odpowiedzi: 4
    Ostatni post/autor: 12-02-2016, 22:36
  2. problem z zalogowaniem na stronę administratora i podstrony witryny
    przez toffik11 na forum Administracja - ogólnie
    Odpowiedzi: 6
    Ostatni post/autor: 14-01-2011, 19:46
  3. Problem z zalogowaniem sie do panela administratora.
    przez Kalaf na forum Administracja Joomla!
    Odpowiedzi: 1
    Ostatni post/autor: 24-08-2009, 16:23
  4. Problem z zalogowaniem do panelu admina
    przez twoface na forum Administracja Joomla!
    Odpowiedzi: 7
    Ostatni post/autor: 21-09-2007, 15:22
  5. problem z zalogowaniem administratora
    przez tymek_xxl na forum Administracja Joomla!
    Odpowiedzi: 0
    Ostatni post/autor: 18-02-2006, 23:22

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •