Aktualizacja 3.7 do 3.8 ręcznie i automatycznie - problem
Wyniki 1 do 10 z 10

Temat: Aktualizacja 3.7 do 3.8 ręcznie i automatycznie - problem

  1. #1
    Przeglądacz
    Dołączył
    21-09-2012
    Wpisy
    60
    Punkty
    2

    Domyślny Aktualizacja 3.7 do 3.8 ręcznie i automatycznie - problem

    Witam, walczę z ostrzeżeniem Warning: Class '\Joomla\CMS\Http\Transport\CurlTransport' not found in /home/konto/domains/mojadomena.pl/public_html/libraries/loader.php on line 648 które to ostrzeżenie występuje po aktualizacji do 3.8.1Odtworzyłem kopie utworzoną akebabackup w wersji 3.7.2 - w tej wersji niema błędów i chciałem ręcznie zaktualizować po kolei plikami Upgrade Package, czyli 3.7.2 do 3.7.3 i tak dalej.
    Sciągnołem sobie paczke Joomla! 3.7.3 Upgrade Package (.zip) ale niestety podczas instalacji ręcznej wyskakuje komunikat: JInstaler::Instalacja: nie można odnaleźć pliku instalacyjnego XML.
    Nie można zainstalować pakietu Joomla przy pomocy instalatora rozszerzeń. Proszę użyć dodatku Aktualizacja Joomla!, aby wykonać aktualizację.
    i koło się zamyka. Czy można jakoś ręcznie (przez ftp) zaktualizować joomla ?

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Bywalec
    Dołączył
    21-03-2017
    Wpisy
    206
    Punkty
    56

    Domyślny

    Cytat Wysłane przez bnet Zobacz wiadomość
    JInstaler::Instalacja: nie można odnaleźć pliku instalacyjnego XML.
    Nie można zainstalować pakietu Joomla przy pomocy instalatora rozszerzeń. Proszę użyć dodatku Aktualizacja Joomla!,
    Od 3.4.8 aktualizacji Joomla nie instaluje się przy pomocy instalatora rozszerzeń, tylko przez 'Komponenty' / 'Aktualizacje Joomla' - tam powinieneś oprócz zakładki 'Aktualizacja bezpośrednia' mieć również 'Prześlij i aktualizuj'

    A.
    Pomogłem? Kliknij: Pomógł - daj punkt. Dzięki!

  4. #3
    Przeglądacz
    Dołączył
    21-09-2012
    Wpisy
    60
    Punkty
    2

    Domyślny

    bardzo dziękuje za szybką odpowiedz, zaraz będe testował tylko nie bardzo wiem czym różnią się te paczki:
    https://downloads.joomla.org/pl/cms/joomla3/3-7-3
    https://downloads.joomla.org/pl/cms/joomla3/

  5. #4
    Bywalec
    Dołączył
    21-03-2017
    Wpisy
    206
    Punkty
    56

    Domyślny

    3.7.2 możesz podnieść od razu do 3.7.5 za pomocą
    https://downloads.joomla.org/pl/cms/...zip?format=zip

    później do 3.8.0:
    https://downloads.joomla.org/pl/cms/...zip?format=zip

    do 3.8.2 analogicznie (ale spróbowałbym aktualizacji automatycznej

    A.
    Pomogłem? Kliknij: Pomógł - daj punkt. Dzięki!

  6. #5
    Przeglądacz
    Dołączył
    21-09-2012
    Wpisy
    60
    Punkty
    2

    Domyślny

    Do 3.7.5 szło wszystko dobrze, niestety po aktualizacji do 3.8.0 znów ten błąd
    Warning: Class '\Joomla\CMS\Http\Transport\CurlTransport' not found in /home/konto/domains/mojadomena.pl/public_html/libraries/loader.php on line 648
    Chociaż w panelu widnieje wersja 3.8.0 to po lewej stronie pojawił się komunikat: nieznany stan aktualizacji joomla, tak samo przy sprawdzaniu aktualizacji rozszerzeńSpróbuje jeszcze ręczne nadpisanie plików przez ftp, wiem że nie tylko ja miałem taki problem po aktualizacji do 3.8 , może po prostu nie przejmować się tym komunikatem ? acz kol wiek nie daje mi spokoju

  7. #6
    Wyjadacz
    Dołączył
    11-08-2006
    Wpisy
    780
    Punkty
    78

    Domyślny

    bnet Widzę, że posiadasz kopię wykonaną przed aktualizacją do 3.8.x. Jeżeli obejmuje ona pliki i bazę to:
    1. Odtwarzasz ją w nowym folderze i bazie danych.
    2. Dostarczasz wyniki z Pomocnika Pisania Postów.

  8. #7
    Bywalec
    Dołączył
    21-03-2017
    Wpisy
    206
    Punkty
    56

    Domyślny

    Chyba się zasugerowaliśmy że to problem z samym procesem aktualizacji, ale jeśli się przyjrzeć komunikatowi to bardzo prawdopodobne że to problem z którymś rozszerzeniem (nieaktualne/niekompatybilne z 3.8.x).

    @bnet przejrzyj czy nie ma aktualizacji do rozszerzeń, ew. popróbuj z wyłączaniem pojedynczo (najpierw tych bardziej 'systemowych' np. do cache itp)

    Oczywiście zrzut z pomocnika dużo wyjaśni.

    A.
    Pomogłem? Kliknij: Pomógł - daj punkt. Dzięki!

  9. #8
    Wyjadacz
    Dołączył
    11-08-2006
    Wpisy
    780
    Punkty
    78

    Domyślny

    bnet Sprawdź czy masz plik /libraries/classmap.php w plikach tej strony z błędami. Jego brak upewni na, że aktualizacja do 3.8.x się nie udała.

  10. #9
    Przeglądacz
    Dołączył
    21-09-2012
    Wpisy
    60
    Punkty
    2

    Domyślny

    Cytat Wysłane przez adam.lachut Zobacz wiadomość
    @bnet przejrzyj czy nie ma aktualizacji do rozszerzeń, ew. popróbuj z wyłączaniem pojedynczo (najpierw tych bardziej 'systemowych' np. do cache itp)
    wszystkie rozszerzenia aktualne, aktualizacje instalowane przed uaktualnieniem joomla, po uaktualnieniu do 3.8 ponownie sprawdzałem czy nie pojawiła się jakaś aktualizacja rozszerzeń


    Cytat Wysłane przez wojsmol Zobacz wiadomość
    bnet Sprawdź czy masz plik /libraries/classmap.php w plikach tej strony z błędami. Jego brak upewni na, że aktualizacja do 3.8.x się nie udała.
    tak, ten plik isnieje

    co ciekawe, raportowanie błędów mam ustawione na proste, po zmianie na brak wszystko wraca do normy joomla sprawdza automatycznie stan aktualizacji joomla i rozszerzeń na pulpicie głównym, po zmianie raportowania na proste, ostrzeżenie się pojawia a stan aktualizacji - nieznany

  11. #10
    Wyjadacz
    Dołączył
    11-08-2006
    Wpisy
    780
    Punkty
    78

    Domyślny

    1. Wrzuć wynik z pomocnika pisania postów.
    2. Osobiście spróbowałbym odtworzyć kopię strony minimum w wersji 3.7.5 na JAMP'ie - wystarczy wersja testowa - i wykonać aktualizację do 3.8.2.

Podobne tematy

  1. artforms - usunąłem ręcznie i nie mogę zainstalować innej wersji
    przez ViperAS na forum Administracja składnikami
    Odpowiedzi: 0
    Ostatni post/autor: 12-12-2007, 20:54
  2. Odpowiedzi: 0
    Ostatni post/autor: 09-12-2006, 15:31
  3. wyłącznie rejestracji mailem
    przez kiszkar na forum Administracja Joomla!
    Odpowiedzi: 3
    Ostatni post/autor: 18-11-2006, 17:04
  4. Jak zainstalować Lxmenu ręcznie
    przez parys na forum Instalacje (Joomla!, składników)
    Odpowiedzi: 0
    Ostatni post/autor: 09-06-2006, 13:56

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •