dostosowanie joomla 2.5 do php 7
Wyniki 1 do 4 z 4

Temat: dostosowanie joomla 2.5 do php 7

  1. #1
    Nowicjusz
    Dołączył
    17-05-2012
    Wpisy
    12
    Punkty
    2

    Joomla! 2.5 dostosowanie joomla 2.5 do php 7

    Mam kilka stron w różnej wersji tj. joomla 2.5 oraz joomla 3.8. Mam pytanie odnośnie xampa i wersji php. Jak zainstaluję wersję xamp php 5.6 to wszystkie strony działają ok. Natomiast w xamp php 7.2.5 joomla 2.5 lub joomla 3.8 z dodatkami niekompatybilnymi z php 7 strony nie wyświetlaj się poprawnie. To oczywiście rozumiem. Pytanie brzmi czy można gdzieś dodać jakiś plik/skrypt, żeby te strony działały poprawnie pod php 7 na xampie? Tak mam na hostingu w Home.pl. Mam ustawione środowisko php 7 ale wszystkie strony działają dobrze. Kazali mi tylko dodać krótki skrypt do pliku htaccess w joomla i trochę zmienić nazwę tego pliku. Ale to nie działa na xampie. Czy jest / znacie jakieś rozwiązanie? Pytam ponieważ słyszałem, że są już komponenty, które nie działają na php 5.6, a ja mam zamiar rozwijać nową stronę i testować ją na php 7. Od razu piszę, że upgrade starych joomli to strasznie dużo pracy w moim przypadku i wolałbym tego uniknąć (poza tym sporo fajnie działających dodatków niekompatybilnych z joomla 3x).

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Bywalec
    Dołączył
    21-03-2017
    Wpisy
    210
    Punkty
    59

    Domyślny

    Nie ma czegoś takiego jak "skrypt do pliku .htaccess" który w czarodziejski sposób dostosuje oprogramowanie (w Twoim przypadku Joomla 2.5) do php 7.x. Dyrektywa którą dopisujesz w .htaccess wymusza użycie dla konkretnego folderu/domeny innej wersji php niż wersja ustawiona domyślnie dla serwera (czyli w rzeczywistości używasz php 5.6 a nie 7.x).

    Możesz zbliżoną funkcjonalność (różne wersje php w zależności od folderu/domeny) uzyskać w XAMP na kilka sposobów (google: 'two php versions in xampp').

    A.
    Pomogłem? Kliknij: Pomógł - daj punkt. Dzięki!

  4. #3
    Wiarus siristru awatar
    Dołączył
    28-05-2009
    Skąd
    Szczecin
    Wpisy
    1 860
    Punkty
    205

    Domyślny

    Ale nie dostosujesz Joomla! 2.5 do php 7, chyba, że zabierzesz się za przepisywanie i modyfikację kodu plików Joomla!
    Chcesz dostosowac 2.5 do php 7? Zrób migrację do 3.x - na pewno mniej pracy niż przepisywanie Joomla 2.5 dla php 7
    Na Forum pomagam bezpłatnie ad maiorem Joomla gloriam
    Mimo pomocy na forum nie dajesz rady? Potrzebujesz by ekspert "zrobił to" za Ciebie?
    Napisz do mnie na PW. Argentum et Aurum nie zawsze jest konieczne ;)

  5. #4
    Nowicjusz
    Dołączył
    17-05-2012
    Wpisy
    12
    Punkty
    2

    Domyślny

    tak podejrzewałem, że tak może to być rozwiązane. Ok postaram się zrobić wg tych tuturiali. Dzięki za odpowiedź.

Podobne tematy

  1. Edycja szablonu w Joomla! 2.5.4 - dostosowanie baneru slideshow.php, javascript
    przez ADyarac na forum Szablony, formatowanie wyglądu
    Odpowiedzi: 1
    Ostatni post/autor: 27-11-2012, 20:50
  2. błąd The requested URL /php-fcgi/php-fcgi-5.default/index.php was not found on this s
    przez majkigru na forum Instalacja, aktualizacja, migracje
    Odpowiedzi: 4
    Ostatni post/autor: 23-12-2011, 10:44

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •