Strona główna otwiera sie bardzo wolno
Wyniki 1 do 10 z 10

Temat: Strona główna otwiera sie bardzo wolno

  1. #1
    Nowicjusz
    Dołączył
    10-03-2018
    Wpisy
    27
    Punkty
    2

    Domyślny Strona główna otwiera sie bardzo wolno

    Witam
    Mam następujący problem
    Strona startowa :
    http://www.gops.krzeszowice.pl/index.php
    otwiera sie bardzo wolno. Gdy już się otworzy - nawigacja po stronie przebiega bez problemów.
    Joomla zaktualizowana do wersji 3.8.8

    Możecie poradzić co może być przyczyną?
    POzdrawiam

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Wiarus siristru awatar
    Dołączył
    28-05-2009
    Skąd
    Szczecin
    Wpisy
    1 932
    Punkty
    211

    Domyślny

    Pffff... connection error oraz timeout. Pingdom Tools nie może nawet dokończyć testów.
    Dopiero za drugim podejściem dopiero udaje się załadować stronę:

    https://tools.pingdom.com/#!/cU5B5i/...e.pl/index.php

    Ponad 40 sekund oczekiwanie na odpowiedź serwera.
    Co to za hosting? ns1.tpnet.pl ? Orange Polska?
    Nie mam doświadczeń z tym hostingiem ale działanie twojej strony nie jest dla nich dobrą reklamą... skontaktuj się z hostingiem... lub zmień na jakiś ludzki.
    Na Forum pomagam bezpłatnie ad maiorem Joomla gloriam
    Mimo pomocy na forum nie dajesz rady? Potrzebujesz by ekspert "zrobił to" za Ciebie?
    Napisz do mnie na PW. Argentum et Aurum nie zawsze jest konieczne ;)

  4. #3

    Domyślny

    U mnie TTFB wygląda gorzej bo 40s to jest super. W przeróżnych odstępach czasu robiłem testy to najczęściej było powyżej 50s

    Jeżeli nic nie instalowałeś w ostatnim czasie lub nie modyfikowałeś skryptów które mogły znacząco spowodować wydłużenie czasu to uderzaj bezpośrednio do hostingu.

  5. #4
    Nowicjusz
    Dołączył
    10-03-2018
    Wpisy
    27
    Punkty
    2

    Domyślny

    Dzięki za zainteresowanie tematem.

    Informatyk GOPS'u twierdzi ,że wina jest po stronie Joomla a nie po stronie hostingu.

    Zastanawiające jest to dlaczego tylko strona główna się tak długo otwiera a pozostałe strony działają normalnie.
    Czy jest możliwe aby ktoś celowo pogrzebał w joomli i spowolnił działanie tylko strony startowej?

    Mam jeszce następujący problem:
    -Wrzucam plik przez TC (normalnie go widzę ,że został przesłany na serwer) natomiast jak chce go otworzyć poprzez stronę to wyskakuje błąd ,że nie znaleziono takiego pliku
    Wcześniej nie było z tym problemu. Czy możliwe jest aby ktoś ograniczył prawa administratora?


    Na stronie głównej zmieniłem TYP POZYCJI MENU z Listy artykułów na pojedynczy artykuł i strona zaczęła chodzić normalnie.
    Czy możliwe jest to aby lista artykułów tak obciążał serwer aby nie mógł sobie z tym poradzić?
    Jak teraz można zrobic przegląd artykułów aby nie starcić na płynności strony?

  6. #5
    Wiarus siristru awatar
    Dołączył
    28-05-2009
    Skąd
    Szczecin
    Wpisy
    1 932
    Punkty
    211

    Domyślny

    To nie koniecznie tak, że problem stanowi strona główna. Użyj adresu jakiejś podstrony np. kontaktu (ale za jakiś czas, nie kiedy już próbowałeś otwierać stronę ze startowej) i zobacz efekt.
    Pierwsze odpytanie serwera tak długo trwa.
    Joomla się nawet nie pokazuje bo serwer nie wysyła danych do wyświetlenia. Więc to raczej nie Joomla.

    A zainstaluj sobie extplorera w Joomli i zobacz czy ten plik widzisz po załadowaniu na serwer jako plik? Może dane w TC prowadzą do innego serwera niż ten na którym jest Joomla?

    Czy lista czy blog, Joomla odpytuje te same tabele.
    Na Forum pomagam bezpłatnie ad maiorem Joomla gloriam
    Mimo pomocy na forum nie dajesz rady? Potrzebujesz by ekspert "zrobił to" za Ciebie?
    Napisz do mnie na PW. Argentum et Aurum nie zawsze jest konieczne ;)

  7. #6
    Nowicjusz
    Dołączył
    10-03-2018
    Wpisy
    27
    Punkty
    2

    Domyślny

    Hello to jeszcze raz ja

    Wiele mi sie wyjaśniło

    Okazało sie ,że w jednym z artykułów znajdował się jeden obrazek który był odpowiedzialny za spowolnienie strony. Po wyrzucenie go strona chodzi płynnie.

    Problem z ftp nadal pozostał

  8. #7

    Domyślny

    Cytat Wysłane przez jkotjkot Zobacz wiadomość
    Okazało sie ,że w jednym z artykułów znajdował się jeden obrazek który był odpowiedzialny za spowolnienie strony
    Obrazek?
    Dla mnie to jest niepojęte aby obrazek spowodował tak długi czas TTFB. Przyczyn długiego czasu może być wiele po stronie serwera jak i skryptów php ale obrazek?

    Może jakiś plugin, który coś robi z obrazkami ale nie sam obrazek. Jestem niesamowicie zaskoczony.

  9. #8
    Wiarus siristru awatar
    Dołączył
    28-05-2009
    Skąd
    Szczecin
    Wpisy
    1 932
    Punkty
    211

    Domyślny

    Ja również. Przecież obrazek jest tylko JEDNYM z elementów które są ładowane na stronie a te są ładowane począwszy od plików php/html (to znaczy ładowany jest wynik php) i wtedy dopiero ładowane są obrazki bo wywołuje je kod strony. Wtedy powinniśmy widzieć przynajmniej część strony a sam obrazek nie powinien pojawiać się przez jakiś czas.

    Brak lub problemy z obrazkiem nie powinny powodować timeout / connection error - to są problemy w komunikacji z serwerem.
    Na Forum pomagam bezpłatnie ad maiorem Joomla gloriam
    Mimo pomocy na forum nie dajesz rady? Potrzebujesz by ekspert "zrobił to" za Ciebie?
    Napisz do mnie na PW. Argentum et Aurum nie zawsze jest konieczne ;)

  10. #9
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    27 297
    Punkty
    1135

    Domyślny

    Informatyk z GOPS-u jest niewątpliwie specjalistą najwyższej klasy. G... widział, G...wie, ale za to ma proste odpowiedzi.
    Oczywiscie, że możliwe jest, że ktoś "pogrzebał" w Joomla i teraz dziala tak wolno.
    Ktoś = krasnoludki, włamywacze, autor/projektant strony. Bo ta strona na tym serwerze jeszcze całkiem niedawno wyglądała jak wygląda, ale działała w miarę sprawnie.
    Sugeruję: zrobić kopię, zainstalować na lokalnym serwerze i zbadać, czy przyczyna jest w serwerze, czy przyczyna jest w "nagrzebaniu w kodzie" (a nie w Joomla - bo Joomla na milionach stron ma się dobrze).
    Korzystaj i ciesz się!
    ===============
    Zwiastun
    Biblioteka Elektronicznej Dokumentacji Joomla!

  11. #10
    Debiutant
    Dołączył
    15-06-2018
    Skąd
    śląsk
    Wpisy
    3
    Punkty
    2

    Domyślny

    Zrób testy na innym hostingu i będzie 100% pewności.

Podobne tematy

  1. Bardzo wolno ładuje się jedna strona
    przez Peterborough24 na forum Optymalizacja i wydajność
    Odpowiedzi: 5
    Ostatni post/autor: 04-09-2017, 11:13
  2. Wolno wczytująca się strona główna
    przez Father23 na forum Bezpieczeństwo
    Odpowiedzi: 2
    Ostatni post/autor: 21-11-2015, 23:45
  3. Podstrony bardzo wolno się ładują
    przez Linkologia na forum Optymalizacja i wydajność
    Odpowiedzi: 4
    Ostatni post/autor: 25-07-2013, 14:49
  4. Wolno ładująca sie strona
    przez jork5 na forum Różne
    Odpowiedzi: 1
    Ostatni post/autor: 06-05-2009, 13:39
  5. Panel admina zawiesza się, działa bardzo wolno
    przez maslow_info na forum Administracja Joomla!
    Odpowiedzi: 7
    Ostatni post/autor: 27-03-2009, 09:57

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •