Pozbycie się /index.php
Strona 1 z 2 12 OstatniOstatni
Wyniki 1 do 10 z 15

Temat: Pozbycie się /index.php

  1. #1
    Nowicjusz
    Dołączył
    06-06-2018
    Skąd
    Poznań
    Wpisy
    24
    Punkty
    2

    Domyślny Pozbycie się /index.php

    Dzień dobry,

    mam w .htaccess taką regułkę:

    RewriteEngine On


    ## Begin - Rewrite rules to block out some common exploits.
    # If you experience problems on your site block out the operations listed below
    # This attempts to block the most common type of exploit `attempts` to Joomla!
    #
    # Block out any script trying to base64_encode data within the URL.
    RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
    # Block out any script that includes a ********** tag in URL.
    RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
    # Block out any script trying to set a PHP GLOBALS variable via URL.
    RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
    # Block out any script trying to modify a _REQUEST variable via URL.
    RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
    # Return 403 Forbidden header and show the content of the root homepage
    RewriteRule .* index.php [F]
    #
    ## End - Rewrite rules to block out some common exploits.



    Chciałbym pozbyć się index.php ze strony głównej. Dodawałem: RewriteRule ^index.php$ http://www.stronaglowna/$1 [R=301,L], ale nic nie działa.

    Macie na to rozwiązanie?

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    27 168
    Punkty
    1125

    Domyślny

    W oryginalnym .htaccess jest odpowiednia reguła. Wystarczy, że włączysz obslugę prostych adresów oraz Przepsiywanie URL. Oczywiście, musisz też zmienić plik htaccess.txt na .htaccess
    Korzystaj i ciesz się!
    ===============
    Zwiastun
    Biblioteka Elektronicznej Dokumentacji Joomla!

  4. #3
    Nowicjusz
    Dołączył
    06-06-2018
    Skąd
    Poznań
    Wpisy
    24
    Punkty
    2

    Domyślny

    Na serwerze mam htaccess.txt oraz .htaccess. W CMS w konfiguracji globalnej przepisywanie adresów oraz proste adresy też włączone.


    Acha, i ten index.php pojawią się dopiero gdy go wpiszę, tzn. nie ma przekierowania na /

  5. #4

  6. #5
    Nowicjusz
    Dołączył
    06-06-2018
    Skąd
    Poznań
    Wpisy
    24
    Punkty
    2

    Domyślny

    Te artykuły nie uwzględniają tego przypadku.

  7. #6
    Bywalec terra awatar
    Dołączył
    26-05-2017
    Skąd
    Wrocław
    Wpisy
    253
    Punkty
    31

    Domyślny

    Uwzględniają bo są to ogólne zasady. W Twoim przypadku, jeśli pokazuje się index to pewnie nie masz aktywnych prostych adresów, albo nie działa plik .htaccess .
    Jeszcze raz:
    ustaw na TAK

    Proste adresy
    Zastosuj przepisywanie URL
    Dodaj przyrostek do URL

    usuń aktualny plik .htaccess i utwórz nowy z pliku htaaccess.txt . Nowo utworzony plik nie może być typu txt. To musi być plik .htaccess bez żadnego rozszerzenia.

  8. #7
    Nowicjusz
    Dołączył
    06-06-2018
    Skąd
    Poznań
    Wpisy
    24
    Punkty
    2

    Domyślny

    Tak, jak napisałem, mam proste adresy i przepisywanie. Na serwerze mam oba pliki .htaccess - bez oraz z txt. Odsyłasz mnie do podstaw, a ja Ci pisze, że je wykonałem.

    Może tu jest problem - # Return 403 Forbidden header and show the content of the root homepage
    RewriteRule .* index.php [F]


  9. #8
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    27 168
    Punkty
    1125

    Domyślny

    A Twoja witryna jest na pewno na serwerze z systemem Apache?
    Korzystaj i ciesz się!
    ===============
    Zwiastun
    Biblioteka Elektronicznej Dokumentacji Joomla!

  10. #9
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    27 168
    Punkty
    1125

    Domyślny

    Cytat Wysłane przez Damian91 Zobacz wiadomość
    Acha, i ten index.php pojawią się dopiero gdy go wpiszę, tzn. nie ma przekierowania na /
    Nie bardzo rozumiem. Pojawia się czy się nie pojawia. Bo jeśli się pojawia dlatego, że go wpisujesz, to może po prostu... nie wpisuj?
    Korzystaj i ciesz się!
    ===============
    Zwiastun
    Biblioteka Elektronicznej Dokumentacji Joomla!

  11. #10
    Bywalec terra awatar
    Dołączył
    26-05-2017
    Skąd
    Wrocław
    Wpisy
    253
    Punkty
    31

    Domyślny

    Cytat Wysłane przez Damian91 Zobacz wiadomość
    Tak, jak napisałem, mam proste adresy i przepisywanie. Na serwerze mam oba pliki .htaccess - bez oraz z txt. Odsyłasz mnie do podstaw, a ja Ci pisze, że je wykonałem.

    Może tu jest problem - # Return 403 Forbidden header and show the content of the root homepage
    RewriteRule .* index.php [F]

    Robiłeś wpisy w .htaccess , a nie wiem co tam dokładnie zrobiłeś, dlatego proponuję usunięcie .htaccess i stworzenie nowego ze standardowymi wpisami, wtedy jest punkt odniesienia dla porad

Strona 1 z 2 12 OstatniOstatni

Podobne tematy

  1. Pozbycie się index.php/en/
    przez jurecky na forum Administracja - ogólnie
    Odpowiedzi: 4
    Ostatni post/autor: 11-02-2013, 22:22
  2. Inna treść na strona.com.pl/index.php/en/ i www.strona.com.pl/index.php/en/
    przez mad80 na forum Rozszerzenia - problemy z obsługą, zarządzaniem
    Odpowiedzi: 3
    Ostatni post/autor: 23-01-2013, 11:35
  3. Nie przekierowywuje na index.php - www.domena.pl/index.php
    przez strona na forum Rozszerzenia - problemy z obsługą, zarządzaniem
    Odpowiedzi: 1
    Ostatni post/autor: 29-08-2012, 13:08
  4. index.php nie dziala, a index.php?option=com_content&view=frontpage owszem
    przez mqpsycho na forum Instalacja, aktualizacja, migracje
    Odpowiedzi: 9
    Ostatni post/autor: 14-07-2011, 22:52
  5. blad generacji adresów www.witryna.index.php/index.php
    przez rafacorex na forum Instalacja, aktualizacja, migracje
    Odpowiedzi: 4
    Ostatni post/autor: 19-12-2010, 22:15

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •