GovArticle i zapisywanie załączników
Wyniki 1 do 10 z 10

Temat: GovArticle i zapisywanie załączników

  1. #1
    Przeglądacz trb awatar
    Dołączył
    04-02-2007
    Wpisy
    44
    Punkty
    10

    Domyślny GovArticle i zapisywanie załączników

    Jak w temacie. Joomla 3.8.13. Komponent GovArticle świeżo pobrany z KDS. Dodawanie kategorii i artykułów przebiega bez zarzutu. Niestety dodawanie załączników nie działa. Próba wybrania jakiegokolwiek pliku się udaje, niestety zapisanie go już nie... Po kliknięciu "zapisz" w artykule zapisują się zmiany, niestety załączniki wylatują. Ich lista pozostaje pusta. Próbowałem z różnymi typami załączników (pdf, doc, zip, rar, jpg). Niestety nic nie działa. Prawa zapisu do katalogów również są prawidłowe... Czy ktoś miał może podobny problem? Z tego co widziałem ktoś już opisywał tego typu działanie komponentu ale bez odpowiedzi.

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    27 307
    Punkty
    1139

    Domyślny

    Raczej nieprawda, że nie da się zapisać załączników. I nie wiem, gdzie widziałeś, że ktoś już opisywał tego typu działanie komponentu i nie otrzymał odpowiedzi.
    1. Aby zapisywać załączniki, musisz skonfigurować komponent do zapisu, o czym przypomina stosowny komunikat. Na karcie Edycja artykułu ustaw opcję Włącz wersje na Tak, a Maksimum wersji na 1000.
    2. Dodatkowo sprawdź, czy w komponencie media ustawiono odpowiednie uprawnienia.
    Przy okazji przypominam, że Joomla nie obsługuje ze względów na bezpieczeństwo załączników w formacie ZIP, w komponencie GovArticle trzeba korzystać z formatu 7z .
    Korzystaj i ciesz się!
    ===============
    Zwiastun
    Biblioteka Elektronicznej Dokumentacji Joomla!

  4. #3
    Przeglądacz trb awatar
    Dołączył
    04-02-2007
    Wpisy
    44
    Punkty
    10

    Domyślny

    Z załącznikami udało się temat rozwiązać. Ostatnio pojawił się inny problem z którym nie umiem sobie poradzić. Adres bip.szlichtyngowa.pl - z komponentu govarticle mam utworzone menu boczne i wybierając z niego jakąś kategorię pojawia się lista podkategorii ale wybierając którąś z nich pojawia się lista artykułów (prawdopodobnie wyróżnionych) z nagłówkiem ROOT przed wszystkimi innymi artykułami . Jest to o tyle uciążliwe że tych artykułów pojawia się długa lista. Niestety nie mogę odnaleźć w którym miejscu można to wyłączyć. Opcja z artykułami wyróżnionym jest złym tropem. Proszę o ew.wskazówke gdzie to można wyłączyć.

  5. #4
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    27 307
    Punkty
    1139

    Domyślny

    Mozesz pokazać na stronie o co chodzi? Przejrzałem całą stronę i nie widze takich sytuacji
    Korzystaj i ciesz się!
    ===============
    Zwiastun
    Biblioteka Elektronicznej Dokumentacji Joomla!

  6. #5
    Przeglądacz trb awatar
    Dołączył
    04-02-2007
    Wpisy
    44
    Punkty
    10

    Domyślny

    Z menu bocznego wchodzę w pierwszy link z menu od góry - BUDŻET. Obok po prawej pojawia się podkategoria "Informacja z wykonania budżetu" i informacja że w tej podkategorii jest 1 artykuł. Po kliknięciu na link podkategorii nie wyświetla się artykuł z tej podkategorii tylko pokazuje się kilkadziesiąt innych artykułów z nagłówkiem ROOT. Są to prawdopodobnie wszystkie artykuły dodane do wszystkich podkategorii. Czy wyjaśniłem to wystarczająco dobrze? załączam screeny. Załącznik 9533Załącznik 9534Załącznik 9535

  7. #6
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    27 307
    Punkty
    1139

    Domyślny

    Spróbuj przebudować (najlepiej oczywiście na kopii) strukturę kategorii i pozycji menu. Pierwszy raz spotykam się z takim efektem.
    Korzystaj i ciesz się!
    ===============
    Zwiastun
    Biblioteka Elektronicznej Dokumentacji Joomla!

  8. #7
    Przeglądacz
    Dołączył
    11-12-2012
    Wpisy
    49
    Punkty
    2

    Domyślny

    Chciałbym odkopać temat. Mam ten sam problem. Najgorsze jest to, że od pół roku wszystko działało i nagle przestało. Maksimum wersji mam ustawione na 1000. Miejsce na serwerze mam. Pliki bezpośrednio przez artykuły -> media się wgrywają. Nagle przestały się wgrywać przez Gov Article w zakładce załączniki. Nie mogę wgrać żadnego pliku (jpg, doc, txt, pdf, png itp). Pliki są małe (kilkaset kb). Mają któtkie proste nazwy, bez spacji i polskich znaków np. plik_1

    Gdzie szukać problemu?

  9. #8
    Wiarus siristru awatar
    Dołączył
    28-05-2009
    Skąd
    Szczecin
    Wpisy
    2 782
    Punkty
    276

    Domyślny

    Masz wersję aktualną odpowiednią dla twojej Joomli?
    Czy podczas grywania widzisz jakieś błędy w konsoli przeglądarki?
    Na Forum pomagam bezpłatnie ad maiorem Joomla gloriam
    Mimo pomocy na forum nie dajesz rady? Potrzebujesz by ekspert "zrobił to" za Ciebie?
    Napisz do mnie na PW. Argentum et Aurum nie zawsze jest konieczne ;)

  10. #9
    Przeglądacz
    Dołączył
    11-12-2012
    Wpisy
    49
    Punkty
    2

    Domyślny

    Wersja Joomla: 3.10.1
    Wersja Gov Article: 3.0.2

    Błędów nie ma żadnych podczas wgrywania. Może to jest związanie z aktualizacją z 3.9.28 do 3.9.10.1?

  11. #10
    Wiarus siristru awatar
    Dołączył
    28-05-2009
    Skąd
    Szczecin
    Wpisy
    2 782
    Punkty
    276

    Domyślny

    Hmmm... a błędy w konsoli podczas wgrywania pliku?
    Na Forum pomagam bezpłatnie ad maiorem Joomla gloriam
    Mimo pomocy na forum nie dajesz rady? Potrzebujesz by ekspert "zrobił to" za Ciebie?
    Napisz do mnie na PW. Argentum et Aurum nie zawsze jest konieczne ;)

Podobne tematy

  1. CK Forms - prześlij plik, załaduj plik - problem z przesyłaniem załączników
    przez jan1975 na forum Rozszerzenia - problemy z obsługą, zarządzaniem
    Odpowiedzi: 0
    Ostatni post/autor: 31-05-2013, 02:00
  2. Dostęp do załączników tylko dla zarejestrowanych - jak
    przez papcio24 na forum Pomysły, sugestie, propozycje, oczekiwania
    Odpowiedzi: 5
    Ostatni post/autor: 10-03-2009, 22:54
  3. Problem z dodawaniem, załączników w JCE Edytor
    przez sylwekb na forum Rozszerzenia - problemy z obsługą, zarządzaniem
    Odpowiedzi: 3
    Ostatni post/autor: 28-01-2009, 15:26
  4. Dodawanie załączników i zdjęć do art'ów
    przez treker na forum Szukam dodatku do Joomla
    Odpowiedzi: 5
    Ostatni post/autor: 30-07-2008, 14:05
  5. ArtForms wysyłka załączników
    przez krystek2007 na forum Administracja składnikami
    Odpowiedzi: 0
    Ostatni post/autor: 07-02-2008, 20:49

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •