[Rozwiązane] Nie mogę zaktualizować J3.9.8 do 3.9.10 - nie pokazuje wiadomości o aktualizacji.
Strona 1 z 2 12 OstatniOstatni
Wyniki 1 do 10 z 15

Temat: Nie mogę zaktualizować J3.9.8 do 3.9.10 - nie pokazuje wiadomości o aktualizacji.

  1. #1
    Bywalec
    Dołączył
    20-11-2006
    Wpisy
    161
    Punkty
    16

    Domyślny Nie mogę zaktualizować J3.9.8 do 3.9.10 - nie pokazuje wiadomości o aktualizacji.

    Mam kilka witryn i tylko jedna zachowuje się specyficznie. W pozostałych czasem musiałem wykonać "reinstall core files", albo wyszukać aktualizacji z menu górnego. W tej jednej nigdzie nie ma żadnej informacji o aktualizacji, żadnych linków. Próbowałem naprawić bazy danych, ale nie ma żadnego przycisku aby wykonać tą operację (czyli zakładam, że bazy są poprawne. Spróbowałem więc ręcznego nadpisania plików (przez ftp) z pobranego pakietu "update" wersji 3.9.10. Nic się nie zmieniło. Miesiąc temu wykonywałem aktualizację tych kilku witryn z J3.9.7 do J3.9.8 i wszystko wtedy zagrało. Proszę o jakieś wsparcie, widzę że seria 3.9 ma kłopoty z aktualizacjami.
    Lepiej mniej, ale lepiej

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Bywalec terra awatar
    Dołączył
    26-05-2017
    Skąd
    Wrocław
    Wpisy
    299
    Punkty
    35

    Domyślny

    Na zapleczu, kliknij SYSTEM->PULPIT->"Test aktualności Joomla" lub "Joomla jest aktualny !"
    powinieneś przejść do ekranu aktualiacji TWOJA_STRONA/administrator/?option=com_joomlaupdate
    Kliknij przycisk "Sprawdź dostępność aktualizacji".
    Jeśli masz wersję Joomla, która wymaga aktualizacji, to pojawi się przycisk "Zainstaluj bezpośrednio", jeśli nie to pojaw się przycisk "Przeinstaluj kluczowe pliki Joomla"

    jeśli chcesz sprawdzić gdzie problem to zajrzyj też tutaj https://docs.joomla.org/Joomla_Updat...rom_Admin_Menu

  4. #3
    Bywalec
    Dołączył
    20-11-2006
    Wpisy
    161
    Punkty
    16

    Domyślny

    Niestety, tak książkowo nie jest. System melduje, że J3.9.8 to wersja jak najbardziej aktualna. Nie widać żadnych linków do aktualizacji, ani żadnych przycisków. Jak rozumiem, poniższa sugerowana sekwencja poleceń SQL wymaga zalogowania się przez jakiegoś np. SQLMyAdmina?

    UPDATE #__menu
    SET component_id =
    (SELECT extension_id from #__extensions WHERE name = "com_joomlaupdate")
    WHERE title = "com_joomlaupdate"


    Jeżeli tak jest, wracamy do epoki kamienia łupanego. A może jest możliwość zasugerowania Joomli, żeby skoczyła do podanego linku z paczką aktualizacyjną? Tylko potrzebna taka metoda i ten link do 3.9.10.
    Lepiej mniej, ale lepiej

  5. #4
    Senior Bazyl awatar
    Dołączył
    02-08-2008
    Skąd
    Skierniewice
    Wpisy
    7 420
    Punkty
    549

    Domyślny

    Pobierasz paczkę aktualizacyjną i instalujesz, jak wszystko inne.
    Działa ;-)

  6. #5
    Bywalec terra awatar
    Dołączył
    26-05-2017
    Skąd
    Wrocław
    Wpisy
    299
    Punkty
    35

    Domyślny

    Cytat Wysłane przez yogi009 Zobacz wiadomość
    Jeżeli tak jest, wracamy do epoki kamienia łupanego. A może jest możliwość zasugerowania Joomli, żeby skoczyła do podanego linku z paczką aktualizacyjną? Tylko potrzebna taka metoda i ten link do 3.9.10.
    Tak operację należy wykonać z poziomu bazy. Spróbuj jeszcze oprożnić bufor i usunąć przestarzałe pliki i dopiero wykonać operacje aktualizacyjne. Instalacja reęczna o której wspomina Bazyl też jest opcją. Ponieważ masz objawy które sugeują, że któraś atualizacja nie została wykonana prawidłowo, to należy wykonać operację na bazie( tak phpmyadmin ;) ).

  7. #6
    Bywalec
    Dołączył
    20-11-2006
    Wpisy
    161
    Punkty
    16

    Domyślny

    Bufor opróżniałem, nie pomogło. Co do rozwiązania zaproponowanego przez Bazyla, nie widzę paczki aktualizacyjnej z J3.9.8 do J3.9.10. Jak wiadomo wersja 3.9.9 miała jakiś grubszy feler, stąd wolałbym jej nie instalować. Czy mam rzeczywiście zaproponować paczkę aktualizacyjną z J3.9.9 do J3.9.10? Opieram się na tym wykazie:

    https://downloads.joomla.org/cms/joomla3/3-9-10

    Muszę spróbować z tym SQL'em...

    - - - Updated - - -

    Błąd

    Analiza statyczna:
    1 błędów zostało znalezionych podczas analizy.

    1. Oczekiwano wyrażenia. (near "SET" at position 16)

    Zapytanie SQL:
    UPDATE #__menu SET component_id = (SELECT extension_id from #__extensions WHERE name = "com_joomlaupdate") WHERE title = "com_joomlaupdate"
    MySQL zwrócił komunikat:
    #1064 - Something is wrong in your syntax obok 'SET component_id =
    (SELECT extension_id from #__extensions WHERE name = "com_jo' w linii 2
    Lepiej mniej, ale lepiej

  8. #7

  9. #8
    Bywalec
    Dołączył
    20-11-2006
    Wpisy
    161
    Punkty
    16

    Domyślny

    Nie wiem, co pomogło, czy ta niezbyt udana zabawa z PHPMyAdmin, czy ponowne kilkukrotne czyszczenie bufora na zapleczu, ważne że w końcu zaproponował mi aktualizację do J3.9.10 i operacja zakończyła się sukcesem. Dzięki za wsparcie! Pozdrawiam.

    - - - Updated - - -

    Cytat Wysłane przez terra Zobacz wiadomość
    pamiętaj że w realnej bazie , przy phpmyadmin, nie używasz #__ tylko przedrostków Twojej bazy
    No tak, dawno się nie bawiłem bazą.
    Lepiej mniej, ale lepiej

  10. #9

  11. #10
    Senior zwiastun awatar
    Dołączył
    20-09-2005
    Wpisy
    27 296
    Punkty
    1135

    Domyślny

    1. Przedstawione przez Ciebie informacje nie dają żadnych podstaw do sformułowania jakiejś diagnozy. Wszystko, co można powiedzieć, to to, że nie działa.
    Bywa. Wszystko na tym świecie czasem się psuje. I bywa, że można naprawiać, ale bywa też, że trzeba naprawić, wymienić, wyrzucić.
    2. Zajmuję się Joomla od zarania. Spotykałem się z drobnymi problemami z aktualizacją, włącznie z takim, że ginęła z jakiegoś powodu (nie sama z siebie) pozycja menu prowadząca do aktualizacji. Raz czy dwa skończyło się przebudową witryny od podstaw (w przypadkach, gdy wcześniej migrowano z Mambo do Joomla, z Joomla 1 do Joomla 1.5, potem 1.6, 1.7... itd miało prawo się przez lata namieszać.
    3. Jeśli nie masz pozycji menu Aktualizacja Joomla, możesz ją odtworzyć. Wejdź do bazy danych innego Joomla, odszukaj w tabeli ####_menu pozycję Aktualizacja Joomla, obejrzyj jej właściwości i załóż taką samą pozycję w bazie danych swojego Joomla.

    Komponent aktualizacji nazywa się com_joomlaupdate, podaję wartości standardowe pól
    id: musi być unikalny
    menutype: main
    title: com_joomlaupdate
    alias: Joomla! Update
    path: Joomla! Update
    link: index.php?option=com_joomlaupdate
    type: component
    published: 1
    parent_id: 1
    level: 1
    component_id: wartość id komponentu z tabeli ####_extensions
    access: 0
    img: class:joomlaupdate
    (najlepiej zrobić sobie zrzut z innej tabeli menu, odszukać pozycję z com_joomlaupdate, skopiować, wkleić do zrzutu tabeli menu ze swojego joomla, poprawić wartość component_id i wrzucić do bazy

    4. Jeśli problemu to nie rozwiąże - oddaj wykonanie pracy w ręce specjalisty, bo nie każdy może wykonywać operacje chirurgiczne na mózgu!
    Korzystaj i ciesz się!
    ===============
    Zwiastun
    Biblioteka Elektronicznej Dokumentacji Joomla!

Strona 1 z 2 12 OstatniOstatni

Podobne tematy

  1. [Rozwiązane] Joomla nie chce się zaktualizować od dłuższego czasu...
    przez vega1977 na forum Instalacja, aktualizacja
    Odpowiedzi: 7
    Ostatni post/autor: 22-03-2019, 22:02
  2. Nie mogę zaktualizować czegokolwiek w Joomla 3.6.4
    przez Optyludek na forum Instalacja, aktualizacja
    Odpowiedzi: 5
    Ostatni post/autor: 29-04-2017, 07:03
  3. FoxContact - wiadomość po wysłaniu wiadomości / po nieuzupełnieniu pola obowiązkowego
    przez marcinp1984 na forum Rozszerzenia - problemy z obsługą, zarządzaniem
    Odpowiedzi: 1
    Ostatni post/autor: 12-06-2013, 13:27
  4. IE nie pokazuje gifa, a Firefox pokazuje
    przez ryzio na forum Administracja Joomla!
    Odpowiedzi: 3
    Ostatni post/autor: 16-03-2007, 13:44
  5. Jak zaktualizować komponent ?
    przez gielo na forum Instalacje (Joomla!, składników)
    Odpowiedzi: 2
    Ostatni post/autor: 13-04-2006, 23:21

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •