[Rozwiązane] Błąd zdjęć pod produktem
Wyniki 1 do 3 z 3

Temat: Błąd zdjęć pod produktem

  1. #1
    Debiutant
    Dołączył
    13-01-2021
    Wpisy
    6
    Punkty
    2

    Domyślny Błąd zdjęć pod produktem

    Witam, mam problem ze zdjęciami pod produktem, korzystam z Hikashop, ustawienia wszystkie przewertowałem 724 razy w poszukiwaniu błędu i nie potrafię tego zrozumieć, do pewnego momentu było wszystko cacy aż zaczął pokazywać mi się błąd. "Undefined variable: image_options in"
    błąd.jpg
    Odnalazłem Linijkę 117 w pliku który jest wskazany i tu stoję..
    linijka php.jpg
    zaznaczona linijka 117. Nie wiem co mogę tu poprawić aby usunąć wyskakujący błąd.


    Szukałem podobnych problemów w internecie ale nigdzie nie znalazłem identycznego kodu a wolę nie ryzykować z eksperymentami, liczę, że znajdę tu ekspertów



    linijka 117: $img = $this->image->getThumbnail(@$image->file_path, array('width' => $width, 'height' => $height), $image_options);

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Wiarus siristru awatar
    Dołączył
    28-05-2009
    Skąd
    Szczecin
    Wpisy
    2 578
    Punkty
    260

    Domyślny

    To nie jest błąd, to tylko powiadomienie.
    Mówi ono dokładnie, że zmienna $image_options została niezdefiniowana.

    Przejdź do Zaplecze -> System -> Konfiguracja globalna -> Serwer -> Raportowanie błędów: ustaw na BRAK.
    To ukryje te powiadomienia.

    Powiadomienie pokazuje się bo w przypadku tych zdjęć zmienna nie przechowuje danych a jest wywoływana.
    Taki drobny lapsus programisty.

    Tutaj jest artykuł wyjaśniający: https://www.stechies.com/notice-unde...riable-in-php/
    Na Forum pomagam bezpłatnie ad maiorem Joomla gloriam
    Mimo pomocy na forum nie dajesz rady? Potrzebujesz by ekspert "zrobił to" za Ciebie?
    Napisz do mnie na PW. Argentum et Aurum nie zawsze jest konieczne ;)

  4. #3
    Debiutant
    Dołączył
    13-01-2021
    Wpisy
    6
    Punkty
    2

    Domyślny

    oo nieee, to było zbyt proste 3 godziny szukałem jak to rozwiązać.. Dzięki wielkie za szybką odpowiedź, Już wszystko działa tak jak chcę.

Podobne tematy

  1. HikaShop - przypisanie szablonu do strony z produktem.
    przez czupkolandja na forum Rozszerzenia - problemy z obsługą, zarządzaniem
    Odpowiedzi: 5
    Ostatni post/autor: 14-03-2015, 20:42
  2. Wyświetlenie opisu kategorii nad produktem
    przez Riaan na forum VirtueMart
    Odpowiedzi: 1
    Ostatni post/autor: 20-03-2009, 09:35
  3. Z tym produktem klienci kupili rowniez to i to...
    przez mariov na forum VirtueMart
    Odpowiedzi: 2
    Ostatni post/autor: 09-09-2007, 13:49
  4. kolejny problem pod jsas przy instalacji joomla pod vistę
    przez eliaszi na forum Instalacje (Joomla!, składników)
    Odpowiedzi: 23
    Ostatni post/autor: 27-08-2007, 22:02

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •