Xampp and mysql
Strona 1 z 2 12 OstatniOstatni
Wyniki 1 do 10 z 12

Temat: Xampp and mysql

Hybrid View

Poprzednia wiadomość Poprzednia wiadomość   Następna wiadomość Następna wiadomość
  1. #1
    Przeglądacz vienio52 awatar
    Dołączył
    14-07-2010
    Skąd
    Wroclaw, PL
    Wpisy
    76
    Punkty
    10

    Domyślny Xampp and mysql

    Cześć,
    próbuję pracować lokalnie w środowisku Xampp z Win11. Bardzo często wysypuje się mysql. Połączenie z bazą jest zestawiane, aby przy następnej próbie było nieudane. Teraz mam takie komunikaty:
    wj@DELLG3 d:\xampp
    # mysqld --console --skip-grant-tables --skip-external-locking
    2023-11-24 12:07:00 0 [Note] Using unique option prefix 'key_buffer' is error-prone and can break in the future. Please use the full name 'key_buffer_size' instead.
    2023-11-24 12:07:00 0 [Note] Starting MariaDB 10.4.28-MariaDB source revision c8f2e9a5c0ac5905f28b050b7df5a9ffd914b7e7 as process 13684
    Cannot find checkpoint record at LSN (1,0x5556)
    2023-11-24 12:07:00 0 [ERROR] mysqld: Aria recovery failed. Please run aria_chk -r on all Aria tables and delete all aria_log.######## files
    2023-11-24 12:07:00 0 [ERROR] Plugin 'Aria' init function returned error.
    2023-11-24 12:07:00 0 [ERROR] Plugin 'Aria' registration as a STORAGE ENGINE failed.
    2023-11-24 12:07:00 0 [ERROR] InnoDB: The innodb_system data file 'ibdata1' must be writable
    2023-11-24 12:07:00 0 [ERROR] InnoDB: The innodb_system data file 'ibdata1' must be writable
    2023-11-24 12:07:00 0 [ERROR] Plugin 'InnoDB' init function returned error.
    2023-11-24 12:07:00 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    2023-11-24 12:07:00 0 [Note] Plugin 'FEEDBACK' is disabled.
    2023-11-24 12:07:00 0 [ERROR] Failed to initialize plugins.
    2023-11-24 12:07:00 0 [ERROR] Aborting
    scr.jpg
    Kopiuję folder poinstalacyjny i Xampp a właściwie baza danych uruchamia się. Dodaję swoje tabele, podmieniam plik ibdata1 i na ogół raz udaje mi się uruchomić środowisko. Sprawdzenie wówczas bazy danych nie wykazuje żadnych błędów w tabelach. Jednak przy następnym włączeniu znów błąd - baza nie uruchamia się. Zaznaczam, że uruchamiam środowisko jako administrator.
    Czy w my.ini standardowe wartości deklarowanej pamięci mam zmienić, zwiększyć?
    Możecie pomóc?
    Kłaniam się
    wieslaw
    --
    pozdrawiam, vienio
    don't give up, to be happy!

  2. #2
    Bywalec pablop76 awatar
    Dołączył
    07-01-2011
    Skąd
    Skierniewice
    Wpisy
    154
    Punkty
    22

    Domyślny

    Walczyłem z tym jakiś czas i się poddałem. Zmieniłem środowisko na Laragon i nie trace więcej nerwów i czasu.
    Paweł
    Moja strona:
    https://web-service.com.pl/
    - Pasjonat Joomla, Polska, Skierniewice

  3. #3
    Przeglądacz vienio52 awatar
    Dołączył
    14-07-2010
    Skąd
    Wroclaw, PL
    Wpisy
    76
    Punkty
    10

    Domyślny

    Dziękuję za podpowiedź. Popróbuję, bo nie daje się pracować z Xampp.
    Pozdrawiam
    --
    pozdrawiam, vienio
    don't give up, to be happy!

  4. #4
    Wyjadacz terra awatar
    Dołączył
    26-05-2017
    Skąd
    Wrocław
    Wpisy
    922
    Punkty
    87

    Domyślny

    Przyczyna jest banalna, przede wszystkim nie można zostawiać xampp'a do włączenia wygaszacza ekranu, bo taki jest właśnie efekt i druga kwestia nie należy istalować xampp'a jak zwykłą aplikację w katalogu ProgramFiles.

  5. #5
    Bywalec pablop76 awatar
    Dołączył
    07-01-2011
    Skąd
    Skierniewice
    Wpisy
    154
    Punkty
    22

    Domyślny

    Z tego co pamiętam xampp instaluje się bezpośrednio na C:\ a jeżeli chodzi o wygaszacz to poważny błąd. Ja jeszcze miałem wrażenie, że jak popełniłem błąd w scss i kompilacja była niepoprawna również wywalało bazę.
    Dlatego wolę Larago, który daje duzo wiecej niż xampp.
    https://www.facebook.com/permalink.php?story_fbid=pfbid02dLgncUsJBZfeAReQqr 3CzxST5uaiCcFTFggV51dN2guzriMu7HQ3pw7R17LKCukVl&id =108869091863179
    Paweł
    Moja strona:
    https://web-service.com.pl/
    - Pasjonat Joomla, Polska, Skierniewice

  6. #6
    Wyjadacz terra awatar
    Dołączył
    26-05-2017
    Skąd
    Wrocław
    Wpisy
    922
    Punkty
    87

    Domyślny

    o lokalizacji Xampp'a decydujesz w trakcie instalacji, generalnie XAMPP nie jest dedykowany WIN, do tego jest WAMP, a wybór pomiędzy AMPem i Laragonem to raczej kwestia potrzeb, ponieważ Laragon jest prostszy, ale nie ma tego wszystkiego co X/W AMP

  7. #7
    Przeglądacz vienio52 awatar
    Dołączył
    14-07-2010
    Skąd
    Wroclaw, PL
    Wpisy
    76
    Punkty
    10

    Domyślny

    Wygaszacz mam wyłączony, tryb zasilania taki, że nie wyłączam ekranu, ani nie usypiam systemu. Instaluję na partycji D:\Xampp. Po prostu dziwi mnie to, że losowo mysql uruchamia się, częściej nie.
    --
    pozdrawiam, vienio
    don't give up, to be happy!

  8. #8

  9. #9
    Przeglądacz vienio52 awatar
    Dołączył
    14-07-2010
    Skąd
    Wroclaw, PL
    Wpisy
    76
    Punkty
    10

    Domyślny

    no nie, sygnalizują to na czerwono przekreślone checkboxy
    Załącznik 10181
    --
    pozdrawiam, vienio
    don't give up, to be happy!

  10. #10
    Wyjadacz terra awatar
    Dołączył
    26-05-2017
    Skąd
    Wrocław
    Wpisy
    922
    Punkty
    87

    Domyślny

    wpisz w WIN do wyszukiwania UAC , wybierz ''Zmień ustawienia funkcji Kontola konta użytkownika ", ustaw na "Nie powiadamiaj nigdy", zrestartuj i wtedy sprawdź, czy MySQL będzie się wyspywać.

Strona 1 z 2 12 OstatniOstatni

Podobne tematy

  1. Odpowiedzi: 0
    Ostatni post/autor: 29-03-2013, 23:38
  2. Bład MySQL podczas instalacji na xampp i wamp
    przez Adish_90 na forum Instalacja, aktualizacja, migracje
    Odpowiedzi: 3
    Ostatni post/autor: 25-08-2011, 21:47
  3. Problem z bazą danych MySQL i Xampp
    przez targos na forum Serwery lokalnie - JAMP, movAMP i inne
    Odpowiedzi: 4
    Ostatni post/autor: 05-10-2010, 13:32
  4. Problem z MySql w XAMPP
    przez Mary$ na forum Serwery lokalnie - JAMP, movAMP i inne
    Odpowiedzi: 2
    Ostatni post/autor: 09-06-2010, 17:47
  5. fjt_cortrivenus_black - and few kłeszczyn
    przez Myszoor na forum Szablony graficzne
    Odpowiedzi: 0
    Ostatni post/autor: 01-05-2006, 10:23

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •