Joomla 4.x i 5.x. Błąd 500 JSON podczas wysyłki emaila testowego. PHP 8.3
Wyniki 1 do 6 z 6

Temat: Joomla 4.x i 5.x. Błąd 500 JSON podczas wysyłki emaila testowego. PHP 8.3

  1. #1
    Nowicjusz
    Dołączył
    07-09-2020
    Wpisy
    17
    Punkty
    2

    Domyślny Joomla 4.x i 5.x. Błąd 500 JSON podczas wysyłki emaila testowego. PHP 8.3

    Mam taki problem.
    Zainstalowany był Joomla 4.4.1 i później zaktualizowany do wersji 5.0.1. Nie używam żadnych zewnętrznych dodatków, gdyż uczę się dopiero CMS. Jest czysta instalacja 4.4.1 i update do 5.0.1
    Mam od początku problem gdyż otrzymuję komunikat
    Kod:
    Wystąpił błąd podczas pobierania danych JSON: kod odpowiedzi HTTP 500. Internal Server Error
    gdy chcę wysłać email testowy. Nieważne co wpiszę w pola dot. poczty, nieważne jakiego daemona wybiorę, zawsze mam ten błąd. Korzystam z PHP 8.3
    Czy wie ktoś w czym jest problem. Przed instalacją i aktualizacją nie było żadnych błędów, wszystkie składniki z wyjątkiem modułu języka były wyświetlone jako OK.

    Nie zauważono innych problemów z działaniem strony czy zaplecza.
    Załączone pliki Załączone pliki

  2. Pani Reklamowa
    Pani Reklamowa jest aktywna
    Avatar Panny Google

    Dołączył
    19-08-2010
    Skąd
    Internet
    Postów
    milion
    Pochwał
    setki
  3. #2
    Bywalec pablop76 awatar
    Dołączył
    07-01-2011
    Skąd
    Skierniewice
    Wpisy
    154
    Punkty
    22

    Domyślny

    Testowałem Joomla 5.0.1 php 8.3 Poczta php Mail działa prawidłowo. Jeżeli masz "czystą" instalacje Joomla to może serwer blokuje wysyłkę? Włącz konfiguracja globalna(serwer) -> raportowanie błędów na maksimum, może dostaniesz więcej informacji.
    Paweł
    Moja strona:
    https://web-service.com.pl/
    - Pasjonat Joomla, Polska, Skierniewice

  4. #3
    Nowicjusz
    Dołączył
    07-09-2020
    Wpisy
    17
    Punkty
    2

    Domyślny

    Raportowanie błędów zostało włączone, ale nigdzie nie widzę żadnych aktualnych logów. Ani w główny katalogu Joomla ani w katalogu administrator nie ma pliku typu .error_log
    System na którym jest zainstalowana Joomla bez problemu przy identycznych ustawieniach wysyła maile bez problemu

  5. #4
    Nowicjusz
    Dołączył
    07-09-2020
    Wpisy
    17
    Punkty
    2

    Domyślny

    Utworzył się plik everything.pho o zawartości:

    Kod:
    #
    #<?php die('Forbidden.'); ?>
    #Date: 2023-12-22 12:39:38 UTC
    #Software: Joomla! 5.0.1 Stable [ Kuboresha ] 28-November-2023 16:00 GMT
    
    
    #Fields: datetime    priority clientip    category    message
    2023-12-22T12:39:38+00:00    CRITICAL 192.168.0.6    error    Uncaught Throwable of type Error thrown with message "Call to undefined function PHPMailer\PHPMailer\filter_var()". Stack trace: #0 [ROOT]/libraries/vendor/phpmailer/phpmailer/src/PHPMailer.php(4108): PHPMailer\PHPMailer\PHPMailer::isValidHost()
    #1 [ROOT]/libraries/vendor/phpmailer/phpmailer/src/PHPMailer.php(2673): PHPMailer\PHPMailer\PHPMailer->serverHostname()
    #2 [ROOT]/libraries/vendor/phpmailer/phpmailer/src/PHPMailer.php(1614): PHPMailer\PHPMailer\PHPMailer->createHeader()
    #3 [ROOT]/libraries/vendor/phpmailer/phpmailer/src/PHPMailer.php(1512): PHPMailer\PHPMailer\PHPMailer->preSend()
    #4 [ROOT]/libraries/src/Mail/Mail.php(153): PHPMailer\PHPMailer\PHPMailer->send()
    #5 [ROOT]/libraries/src/Mail/MailTemplate.php(312): Joomla\CMS\Mail\Mail->Send()
    #6 [ROOT]/administrator/components/com_config/src/Model/ApplicationModel.php(1221): Joomla\CMS\Mail\MailTemplate->send()
    #7 [ROOT]/administrator/components/com_config/src/Controller/ApplicationController.php(270): Joomla\Component\Config\Administrator\Model\ApplicationModel->sendTestMail()
    #8 [ROOT]/libraries/src/MVC/Controller/BaseController.php(730): Joomla\Component\Config\Administrator\Controller\ApplicationController->sendtestmail()
    #9 [ROOT]/libraries/src/Dispatcher/ComponentDispatcher.php(143): Joomla\CMS\MVC\Controller\BaseController->execute()
    #10 [ROOT]/libraries/src/Component/ComponentHelper.php(361): Joomla\CMS\Dispatcher\ComponentDispatcher->dispatch()
    #11 [ROOT]/libraries/src/Application/AdministratorApplication.php(150): Joomla\CMS\Component\ComponentHelper::renderComponent()
    #12 [ROOT]/libraries/src/Application/AdministratorApplication.php(195): Joomla\CMS\Application\AdministratorApplication->dispatch()
    #13 [ROOT]/libraries/src/Application/CMSApplication.php(306): Joomla\CMS\Application\AdministratorApplication->doExecute()
    #14 [ROOT]/administrator/includes/app.php(58): Joomla\CMS\Application\CMSApplication->execute()
    #15 [ROOT]/administrator/index.php(32): require_once('...')
    #16 {main}
    Być może brakuje mi modułu php83-openssl, ale nie występuje on w wersji 8.3 chyba że skrywa go inny pakiet, którego mi brakuje

  6. #5
    Nowicjusz
    Dołączył
    07-09-2020
    Wpisy
    17
    Punkty
    2

    Domyślny

    Tyle że openssl jest aktywny. Po wywołaniu instrukcji php -i otrzymuję informację:


    Kod:
    openssl
    
    
    OpenSSL support => enabled
    OpenSSL Library Version => OpenSSL 1.1.1t-freebsd  7 Feb 2023
    OpenSSL Header Version => OpenSSL 1.1.1t-freebsd  7 Feb 2023
    Openssl default config => /etc/ssl/openssl.cnf
    Nie wiem w czym jest problem.

  7. #6
    Nowicjusz
    Dołączył
    07-09-2020
    Wpisy
    17
    Punkty
    2

    Domyślny

    Problem był w braku pakietu php83-filter. Po jego zainstalowaniu wszystko działa.

Podobne tematy

  1. Wystąpił błąd podczas pobierania danych JSON: kod odpowiedzi HTTP 0.
    przez Saluno na forum Administracja - ogólnie
    Odpowiedzi: 3
    Ostatni post/autor: 22-03-2017, 17:59
  2. Wystąpił błąd podczas przetwarzania następujących danych JSON:
    przez maisa na forum Administracja - ogólnie
    Odpowiedzi: 0
    Ostatni post/autor: 31-01-2017, 00:32
  3. W ustawienaich PHP na serwerze musi być włączona obsługa JSON
    przez Gaikos na forum Instalacja, aktualizacja, migracje
    Odpowiedzi: 2
    Ostatni post/autor: 06-01-2013, 18:32
  4. Wysyłanie emaila z załącznikiem
    przez freebird na forum Rozszerzenia - problemy z obsługą, zarządzaniem
    Odpowiedzi: 0
    Ostatni post/autor: 23-08-2009, 16:37
  5. FacileForms wysyłanie potwierdzającego emaila
    przez Tomekm22 na forum Administracja składnikami
    Odpowiedzi: 0
    Ostatni post/autor: 07-06-2009, 20:01

Reguły pisania

  • Nie możesz zakładać nowych tematów
  • Nie możesz dodawać wypowiedzi
  • Nie możesz dodawać załączników
  • Nie możesz poprawiać swoich postów
  •